MariaDB version requirments

3 months 1 week ago #325215 by dewittds
MariaDB version requirments was created by dewittds
I was informed by Bluehost that they currently suppport only MySQL 5.6.41-84.1 and if I need to change that I would have to go to a VPS. Not in budget for this small non profit organization. I have worked with A2 hosting out of Michigan for a small static work site for years. The do not support MySQL but are currently running MariaDB and the version is 10.6.
Will this work for Joomla, CB and CBsubs?
If not and recommendations for alternate hosting provider.

Thanks,
David DeWitt

Please Log in to join the conversation.

3 months 1 week ago #325216 by dewittds
Replied by dewittds on topic MariaDB version requirments
One other question. What version of CB will stop supporting MySQL 5.6.41-84.1? The pop up message says next stable. Is there a version number I should watch for. Or will it not update if I have out of date MySQL?

Thanks again,
David

Please Log in to join the conversation.

3 months 1 week ago - 3 months 1 week ago #325217 by krileon
Replied by krileon on topic MariaDB version requirments
Bluehost is in the same "do not use" group as HostGator and any other EIG hosting. EIG group buys up hosts, fires most of the staff, then lets the hosting platform stagnate. You will likely never be able to upgrade to a modern environment on either of them. My recommendation is to change hosts. We cannot continue to hold CB in the past because of these hosts. See my below reply regarding this.

www.joomlapolis.com/forum/153-professional-member-support/243946-community-builder-no-longer-compatible-with-mysql-5-6#324792

Both Siteground and Dreamhost are solid hosting providers that provide modern hosting environments within the price range of Bluehost and HostGator. A2Hosting should also be fine.

It's possible we may change this depending on feedback, but so far we've not had enough feedback to consider still setting a MySQL 5.6 minimum, which is EOL (end-of-life) as we no longer want to support EOL environments. At this time the minimums are still planning to be the following.

PHP: 7.4.0
MySQL: 5.7.8
MariaDB: 10.2.7

What version of CB will stop supporting MySQL 5.6.41-84.1?

CB 2.7.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.165 seconds

Facebook Twitter LinkedIn