Problem with Remember me in CB login

11 years 2 months ago #76905 by Swiftek
:pinch: :blink: :ohmy: :woohoo: Ok, I'll bite...

I would categorize your assessments of Vista, Joomla 1.5 and JFusion as "inaccurate" at best.

Joomla 1.5 has no bugs that I've seen and almost every extension that works in 1.0 also works in 1.5 with legacy turned on. Migration is a snap if you handle the extensions separately. Legacy extension database tables can be manually imported without any migration at all, so you just migrate the core, install the extensions and then drop and re-import their database tables from your 1.0 install. Bing, bang, boom, and you're done.

As for JFusion being "laggy", it sounds like you need a better hosting service. I actually only use JFusion to frame the forum into a Joomla component page. I use the RokBridge Joomla to phpBB (the best board on the web) bridge. It's the bomb.

Regardless, it sounds like you have a completely different issue than I did. Sadly, it's an issue that would be eliminated if you upgraded to modern software.

As for Vista, it's the most sophisticated and powerful operating system ever created and has no more problems than any other. That is a myth perpetuated by people who have more money than brains (aka Apple owners) and others who have some unrelated problem and blame it on the OS. Bad-mouthing Windows and/or insisting that XP is better than Vista shows extreme lack of experience with computers and computer users.

For the record, I am no cheerleader for MSFT, I just recognize that they happen to have the best dog in the race for the average user. From a technical point of view, Linux is my new fave. I am however, a happy fan of Joomla.

Keep it light, fellas.:P

Got Tech?
11 years 2 months ago #76906 by Swiftek
Rapunzl wrote:

You stated yourself that the problem was apparently due to cookies being turned off and wanted the problem solved. It's working as it should, so I don't understand the problem. (If cookies are disabled, the browser will not remember the login.)

:blink: I most certainly did NOT. You seem to be very confused.

(Please reply in your own post rather than editing mine as if I had done something wrong.;) )

Post edited by: Swiftek, at: 2008/10/10 16:44

Got Tech?
11 years 2 months ago #76908 by beat
MOD NOTE: can we please keep on topic in here, please ?

ok to reply to why: it's neither joomla's or CB's fault !

The remember-me of Joomla 1.5 API changed since 1.5 RC 1 and the legacy API of Joomla 1.5 didn't follow for good understandable reasons. Thus it doesn't work in CB 1.1, as quite a few other things (see CB 1.1 bugs forum stickies for the top-20 list...(there are over 50 other smaller issues with CB 1.1 on Joomla 1.5).

In a over a year-long development effort, all of those issues are fixed in CB 1.2 RC 3 (see its identified issues forum for the full list of identified issues).

We recommend using CB 1.2 RC 3 for Joomla 1.5, and not CB 1.1 (see left side column).

There are the identified issues and a few more problems in the new API not affecting current CB 1.2 RC 3 uses that need to be fixed before we release CB 1.2 Stable for free download. It's not to far away, but if you need it now and/or wish to help us work even faster on CB, then you can always subscribe to the CB documentation (Thank you very much to all doc subscribers, who make all of this possible, each subscription makes a real difference for us!).

Hope that clarifies and gives an easy solution to all those needing a CB running well over a Joomla 1.5. ;)

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
11 years 2 months ago #76911 by Swiftek
I believe that most of my post was on topic.

The solution for this issue is in my posts. I'll paraphrase it here:

Upgrade to Joomla 1.5 and use the code provided by FEENDISH or purchase the paid version of Community Builder (see the left column here) to fix the "Remember Me" issue.

The only off topic post I see here is from Repunzl. Who's talking about disabling cookies?

I'm done.

Got Tech?
11 years 1 month ago #78604 by AJStevens
I have this issue too, and have used FEENDISH's code.

I have seen an improvement, the lefthand user profile area stays logged in now, however if in the FireBoard forums, it still goes back to Guest, after a refresh then users are logged back in again.

Obviously FEENDISH's code is on the right lines, but the FireBoard must be storing or using a different value or mechanism that also needs accounting for in this code?

Can anyone help?

We're using Joomla 1.5 and CB 1.1.
11 years 1 month ago #78605 by Swiftek
You will not get any help from the CB folks on this issue. They've already said that they have no intention of making any further changes to the free version (1.1).

Your only option is to tolerate it or upgrade to the paid version (1.2).

Good luck.

Got Tech?
Moderators: beatnantkrileon
Time to create page: 0.434 seconds

Facebook Twitter LinkedIn