Problem with Remember me in CB login

11 years 6 months ago #80666 by mynameismonkey
Hallo all, I have a question before I commit to subscribing, I've searched the forums and only found fuzzy answers, so I'd like to phrase it a certain way:

I am pulling together a site built around a very active PHPBB3. I used jfusion to sync up Joomla, and the PHPBB3 will remain the primary user authentication.

I would like to add CB to the site, but need to know if PHPBB3 can remain as the primary registration. Meaning, users will register thru PHPBB3 which will make a CB profile available to them, and these profiles will be single signon between the two apps.

Now that I have imported the current users, I am not tied to jfusion, as long as CB can adequately log my members in from Joomla to PHPBB3 and vice versa.

Thanks in advance for your comments,

Jaz
11 years 6 months ago #80729 by AJStevens
mynameismonkey, your post has nothing to do with this thread, please don't hijack threads, start your own with a title including CB and phpbb3, you might get a useful response.
Can a mod sort this out please.
11 years 6 months ago #80799 by trevorz28
Hello,

I have been having the issues with the login for awhile, and I see the issue logged and a patch now available.

I am a novice with the Joomla stuff, can someone please explain simply how to apply the patch. Which files I need etc.

Thank you very much,
Trevor.
11 years 6 months ago #80811 by AJStevens
hi Trevor

Download the 13662.patch file and open with a text editor. Inside is part of legacy.php

The new code to add to your legacy.php file is the lines begining with + (but don't put the + characters in your legacy.php file!), and need to be placed in the correct location (between the top and bottom code that does not start with +'s. There's also a line begining with @ that gives an approx. line number of where to place the new code.

This file is based on the latest version of Joomla, if you have an older one, you may have to hunt around your legacy.php file to find the right bit, or upgrade first.

Alternatively, if you are a newbie, it's in the SVN, so I suspect will be in the next release, if you can wait.
11 years 5 months ago #80883 by trevorz28
Thanks for the info. That's what I did, and it doesn't appear to be working, however, it could be related to the remember me plugin.... I guess I got more work to do!
11 years 5 months ago #81178 by AJStevens
Be sure you have the remember me and legacy pluggin in the right order, "Remember Me" has to have a higher sort order than "Legacy" as you look at it (but which is a LOWER sort NUMBER (I wouldn't recommend they have the same number either, slightly confusing if you're a newbie or doing this late at night).

Someone also suggested these need to be "next" to each othe/nothing inbetween them.

I would also advise having these first (1,2 not 0,1) before any other system plugins.

Post edited by: AJStevens, at: 2008/12/04 09:55
Moderators: beatnantkrileon
Time to create page: 0.412 seconds

Facebook Twitter LinkedIn