[Joomla 1.5RC3-FIX] Profile update cb.core foreach

11 years 5 months ago #65556 by javidanville
Solved so far I think.

I download this file, a new cb_core and replaced in components\com_comprofiler\plugin\user\plug_cbcore, it works!
11 years 5 months ago #66604 by fLaIr
beat wrote:

A reply was just posted at joomla forum here:

forum.joomla.org/index.php/topic,223385.msg1036999.html#msg1036999

Could someone please check that changing that line in cb.core.php plugin file does fix the problem, and that now the user parameters are visible and can be changed and saved ?

Thanks in advance for your help,


i have just freshly installed J1.5.3stable + CB1.1

i got the problem with the foreach error on line 240 i guess it was and i couldnt create new users (not via admin nor frontend). when clicking "save" or "send registration" respectively it kept telling me to enter a valid password.. which i definetly did..

so i found this tread.. tried the fix with switching those two lines

$userParams = array();
$userParams = $this->_getUserParams($ui, $user);

changed to

$userParams = $this->_getUserParams($ui, $user);
$userParams = array();


after that the error msg disappeared but i still cannot create users for the same reason.

then i tried the fix mentioned in the thread beat was referring to in the quote above but it didnt have any visable effect

greets

[edit]

i know the password validation problem has already been posted and you know about it. but not everyone has access to CB1.2 RC and this is a real major problem so any help or fix would be very very appreciated!

Post edited by: fLaIr, at: 2008/06/27 13:04
11 years 4 months ago #69804 by logaus
I'm too lazy to look it more but you can get profile updating to work disabling JUser class from function _getUserParams

For example:

function _getUserParams($ui, $user,$name="cbparams") {
global $mainframe;

$result = array();

if (class_exists("JUser")) {

Change JUser for example to JUser2, obviously it's because 1.5

Post edited by: logaus, at: 2008/07/29 22:51
11 years 4 months ago #70059 by gemnet
First, sorry for my english and greetings from Italy! :whistle:
I passed a lot reading all your message here and thanks to all of you I solved the problem (I hope, it worked for me and for some others).. and I prepared a new com_comprofile...
If for joomlapolis is ok to distribuite a such not-safe version, I will be happy to publish it here. If not, well... let's wait!

gEmnet
11 years 3 months ago #71417 by barmuudo
IMPORTANT: Joomla/Mambo Community Builder 1.1 ("CB") is for:
- Joomla! 1.0.x (including 1.0.13) and Joomla! 1.5 RC 1.
- Mambo 4.5.2.0-4.6.2
(Joomla 1.5 below 1.5 RC 1 and Mambo below 4.5.2.0 are not supported)

basiccally wat i want to say is i had a problem with this things components/com_comprofiler/plugin/user/plug_cbcore/cb.core.php on line 240
i try to follow everystep u guys was telling and fixing things but it didn't work for me i get fetup.no working for me .what i did is to try my self and i don't know anything abot this css or php things but i fix my problem cuz some people say..... what i did was to switch two lines of code between each other, so from this

$userParams = array();
$userParams = $this->_getUserParams($ui, $user);
i changed to this:
$userParams = $this->_getUserParams($ui, $user);
$userParams = array();

i done and i follow the steps but not working..so i try my won way...and am using
Linux srv13.000webhost.com 2.6.25-burstnet #4 SMP Sun Apr 20 17:41:00 EDT 2008 i686
Database Version: 5.0.45-community
Database Collation: utf8_general_ci
PHP Version: 5.2.6
Web Server: Apache
Web Server to PHP interface: apache2handler
Joomla! Version: Joomla! 1.5.6 Production/Stable [ Vusani ] 12-August-2008 22:00 GMT

for give me i wrote alot ..i don't know how to explain you guys..plz download this rar inside is cb.core.php and replys the one u got..and plz tell me if this fix...cuz my is perfect now
uploads.bizhat.com/file/254173
11 years 3 months ago #71916 by fLaIr
hello barmuudo
thanks for your file
ive tested it and it works partly

when i try to register a new user it says

Fehler

* JFTP::login: Unable to login
* JClientHelper::setCredentialsFromRequest failed

Nachricht

* Sie müssen sich erst anmelden!

Bitte anmelden, um auf den internen Bereich der Webseite zugreifen zu können!

The part below says that you first have to login before you can access this intern part of the website

below that there is another form to register a new user (it doesnt have the images of cb like image for necessary fields)
when i register a user there it works!

could you explain what you did with your cb.core.php?

@gemnet: i would be very happy to see your solution!
Moderators: beatnantkrileon
Time to create page: 0.429 seconds
Facebook Twitter Google LinkedIn