field values in languages with UTF-8

11 years 11 months ago #52484 by tomjoe
I have a site with Joomla 1.0.13 and CB 1.1.0. The side is entirely in English incl. all CB field labels, but some users want to enter field values in other languages, e.g. Russian, Thai, Chinese. This is possible in content items, but when I enter into a CB field, I get the Unicodes after saving.

If possible I don't want to install a language pack. Anyway, that might help for one language only.

Any help is highly appreciated.
11 years 11 months ago #52485 by beat
- What's the charset of your site (you see that in the header of the source html of any page) ?

- Is this for field contents from frontend or for multiple fields in backend ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
11 years 11 months ago #52507 by tomjoe
Gosh!! What a stupid mistake I made. Just put a new template in and forgot to write UTF-8 in the header. After I changed that, everything works fine now.
What I meant was entering a value into an address field from the frontend.
Another condition of course is to set the database to UTF-8. That I had done already.
Thanks a lot Beat for giving the right hint.
Moderators: beatnantkrileon
Time to create page: 0.399 seconds

Facebook Twitter LinkedIn