Plugin Error

13 years 1 month ago #77533 by richardint
Plugin Error was created by richardint
When I try to upload a plugin through CB I receive the following error:

Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: Entity: line 1: parser error : Start tag expected, '<' not found in /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 168

Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: in /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 168

Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: ^ in /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 168

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/library/cb/cb.installer.php:168 Stack trace: #0 /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/library/cb/cb.installer.php(168): SimpleXMLElement->__construct('???????Mac OS X...') #1 /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/library/cb/cb.installer.php(143): cbInstaller->isPackageFile('/Users/richardi...') #2 /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/library/cb/cb.installer.php(65): cbInstaller->findInstallFile() #3 /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/admin.comprofiler.controller.php(3925): cbInstaller->upload('/Users/richardi...') #4 /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/admin.comprofiler.controller.php(455): installPluginUpload() #5 /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/admin.comprofiler.p in /Users/richardint/Sites/CMS/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 168

Any help would be appreciated

Please Log in to join the conversation.

13 years 1 month ago #77534 by nant
Replied by nant on topic Re:Plugin Error
richardint wrote:

Any help would be appreciated


Would really help to know:

- what joomla/mambo version?
- what CB version?
- what plugin are you trying to install???

Please Log in to join the conversation.

13 years 1 month ago #77537 by richardint
Replied by richardint on topic Re:Plugin Error
nant wrote:

richardint wrote:

Any help would be appreciated


Would really help to know:

- what joomla/mambo version?
- what CB version?
- what plugin are you trying to install???


Thanks for the help.

Here's the info:

Joomla 1.5.3
CB 1.2 RC3

Tried a few and have the same error:
CBcaptcha 2.2 (I think - latest version anyway)
Photogallery

Thanks!

Please Log in to join the conversation.

13 years 1 month ago #77548 by beat
Replied by beat on topic Re:Plugin Error
Sorry to ask a few more questions:
- Which PHP version ?
- What's the default charset of your server system (is there at least one loaded) ?
- Did you check for the XML file in the package to be starting with a "<" as first character ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

13 years 1 month ago #77550 by richardint
Replied by richardint on topic Re:Plugin Error
Thanks for your help. Here's the info:

- PHP Version 5.2.6
- For the charset I haven't a clue - I'm running on Mac OS X Leopard. If you could tell me where to look I'll certainly check this out
- Here are the first few lines in the XML package:

<?xml version="1.0" encoding="UTF-8"?>
<!--
/**
* Joomla Community Builder User Plugin: plug_cbprofilegallery
* @version $Id$
* @package plug_cbprofilegallery
* @subpackage cb.profilegallery.xml
* @author Nant, JoomlaJoe and Beat
* @copyright (C) Nant, JoomlaJoe and Beat, www.joomlapolis.com
* @license Limited www.gnu.org/copyleft/gpl.html GNU/GPL
* @final 1.0 RC2
*/
-->
<cbinstall version="1.0.3" type="plugin" group="user">
<name>CB Profile Gallery</name>
<author>Nick A.</author>
<creationDate>03 August 2006</creationDate>
<copyright>(C) 2005 joomlapolis.com</copyright>
<license> www.gnu.org/copyleft/gpl.html GNU/GPL
<authorUrl> www.joomlapolis.com
<version>1.0</version>
<description><![CDATA[
<div align="left">


Thanks for your help!

Post edited by: beat, at: 2009/07/04 12:26

Please Log in to join the conversation.

13 years 1 month ago #77838 by richardint
Replied by richardint on topic Re:Plugin Error
Any ideas on what's wrong?
Thanks

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.201 seconds