Plugin Error

13 years 1 month ago #77851 by beat
Replied by beat on topic Re:Plugin Error
Works fine on similar test-settings on a test-machine here.

I'm a little stumped on that one. Looks like a PHP library or your libxml could have a problem, but it's hard to tell what's wrong on the system.

Make sure you have SimpleXML and libxml installed and up to date.

Alternatively, you can avoid using that library by uncommenting the first define at top of administrator/components/com_comprofiler/library/cb/xml/cb.xml.simplexml.php

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

13 years 12 hours ago #81072 by mjsoules
Replied by mjsoules on topic Re:Plugin Error
Sorry to bother you as I know this plugin was developed completely separately, but I'm getting the exact same error. I really prefer jDownloads over DocMan for my site, but this plugin is crucial.

I tried uncommenting the first define in the file as suggested, but that generated this error:

XML Parsing Error at 6:107. Error 9: Invalid characterXML Parsing Error at 6:107. Error 9: Invalid characterXML Parsing Error at 6:107. Error 9: Invalid character
Fatal error: Call to a member function children() on a non-object in /home/eatve0/public_html/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 614

Has anyone gotten this to work correctly after seeing this error? If so, what did you do?

This is my first time encountering this error.

Thanks for the help,
Melanie

Joomla 1.5.7
CB 1.2RC3
PHP 5.2.6

Please Log in to join the conversation.

12 years 11 months ago #82959 by benech
Replied by benech on topic Re:Plugin Error Jdownloads
When I try to install "Jdownloads CB plugin" from CB "plugin management" menu I also got the following error message.

My config is :
jDownloads CB Plugin : 1.0.2
jDownloads : 1.4 RC
CB : 1.2 RC4
Joomla : 1.5.8 Legacy 1.0

Error message :
Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: Entity: line 6: parser error : Input is not proper UTF-8, indicate encoding ! Bytes: 0xC7 0xF6 0x7A 0xFC in /web/.../www/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 168

Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: 006 Web Media Online, (C) 2007 Sigsiu.NET, (C) 2007 Simple-Quality.de, (C) 2008 in /web/.../www/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 168

Warning: SimpleXMLElement::__construct() [simplexmlelement.--construct]: ^ in /web/.../www/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 168

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /web/.../www/administrator/components/com_comprofiler/library/cb/cb.installer.php:168 Stack trace: #0 /web/.../www/administrator/components/com_comprofiler/library/cb/cb.installer.php(168): SimpleXMLElement->__construct('<?xml version="...') #1 /web/.../www/administrator/components/com_comprofiler/library/cb/cb.installer.php(143): cbInstaller->isPackageFile('/web/...') #2 /web/.../www/administrator/components/com_comprofiler/library/cb/cb.installer.php(65): cbInstaller->findInstallFile() #3 /web/.../www/administrator/components/com_comprofiler/admin.comprofiler.controller.php(3978): cbInstaller->upload('/web/federation...') #4 /web/.../www/administrator/components/com_comprofiler/admin.comprofiler.controller.php(455): installPluginUpload() #5 /web/.../www/administrator/components/com_comprofiler/admin.comprofiler.php(29): require('/web/federa in /web/.../www/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 168

Please Log in to join the conversation.

12 years 11 months ago #83042 by benech
Replied by benech on topic cb.installer.php corrupted
There are some strange characters in the cb.installer.php file, may be corrupted ?

Attachment cb.doc not found

Attachments:

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.185 seconds