Text Formatting issue in automatic responded mails

13 years 7 months ago #83069 by Onkel Tom
Hello,

i am using the autowelcome plugin for the new CB release 1.2 RC4. Everything works fine, but there is a formatting issue in the text of the welcome mails (and in normal mails sent by the PM funktion, too).

Example: The header consists of some general advise text like "... Der Benutzer kennt nicht Deine hinterlegte E-Mail Adresse. Falls Du aber darauf antwortest, wird er Deine E-Mail Adresse natürlich sehen können."
After this lines you normally would expect a linefeed and then the message text starting:

"Hello Dieter, welcome aboard ..."

But the issue is, that the linefeed is not given and the text of the automatic header and the normal message text are all in one. Like this:

"... Der Benutzer kennt nicht Deine hinterlegte E-Mail Adresse. Falls Du aber darauf antwortest, wird er Deine E-Mail Adresse natürlich sehen können. \r\n Hello Dieter, welcome aboard ..."

Did you note the "\r\n" in the text ? normally this is code for formatting the text right that way i want to have it, as \r\n are the Escape Codes for linefeed on Windows and linux Systems. But obviously it doesnt work.

I spent some hours with trying out several Coding in the language files, where the automatic text items are placed, but no chance, i failed.

Is there somebody who solved this problem already and can tell me the solution ?

Thanks
Tom

PS: When reading the post after submitting i saw, that the rn code has been submitted without the backslashes befor the r and the n. So please consider the r and the n code as set together with a leading backslash, this is a necessary character for correct coding.

Post edited by: Onkel Tom, at: 2008/12/21 22:51

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.153 seconds

Facebook Twitter LinkedIn