Registration with aproval failing?

15 years 7 months ago #1199 by rick
Nick,

I just checked mine and it does allow the user to come in without confirmation or Authorization. I checked all this on RC1 and it worked now it does not with RC2. As to the settings they are correct. As to the log in module, my guess is this is the problem, I am using the SMF login module, it is the same module that I used under RC1. I just tried the CBRC2 login mod but it still does not work with SMF.

I know that this is not CB's issue entirly but do you or anyone else have a solution to this problem. I would actually prefer to use the CB login mod but I have a reasonably large community using SMF so need this functioanlity.

Just unpublished the SMF login and published the CB login and now Joomla functions properly but SMF does not.

One thing that you might want to look at/enhance. When a person first registers then attempts to login before confirming it says your account has not yet been approved. In actuallity it should say something to the effect "You have not confirmed your account as stated in the email sent to you"

Please help,

Rick

Running:
Joomla! 1.0.7 Stable
Community Builder 1.0 rc2
SMF 1.1 RC2

Please Log in to join the conversation.

15 years 7 months ago #1202 by nant

I just checked mine and it does allow the user to come in without confirmation or Authorization


Ok if this is the case that means that you have both CB parameters set to No. This means that the anybody submitting a valid (meaning no username duplication and mandatory fields, etc) registration application is automatically granted access - immedeately. So this is what you are experiencing - am I right? or have a missed something?

Please Log in to join the conversation.

15 years 7 months ago #1210 by Manoxtra
nant wrote:

I just checked mine and it does allow the user to come in without confirmation or Authorization


Ok if this is the case that means that you have both CB parameters set to No. This means that the anybody submitting a valid (meaning no username duplication and mandatory fields, etc) registration application is automatically granted access - immedeately. So this is what you are experiencing - am I right? or have a missed something?


Well ive set both options to YES, so it should work like i said, first activation of registration with emaillink, after that users can login.

I do use the CB login, it was in the package and it shows messages and the picture of the user, no doubts here...

Nant, if you want you could test it yourself by registrating at my site and directly afterwards loging in so i didnt approve it.

After that maybe I can upgrade you to admin so you can see the settings....?

dont know how to make this issue more clear then experiencing it yourselves... :side:

Please Log in to join the conversation.

15 years 7 months ago #1211 by rick
Nick,

I may not have made myself clear, when using the CB login module the validation process works fine but it does not login to SMF. When using the SMF login module it logs into SMF and Joomla but the registration process does not function properly.

Is there any chance that the CB login mod can be upgraded with the option to also login to SMF?

I can't imagine that I am the only person using Joomla 1.04 CB 1.1RC2 and SMF 1.1RC1. If there is anyone else with this config can you please reply here and let me know what I am doing wrong.

Thanks,

Rick

Running:
Joomla! 1.0.7 Stable
Community Builder 1.0 rc2
SMF 1.1 RC2

Please Log in to join the conversation.

15 years 7 months ago #1215 by nant
Ok - I have PMed Manoxtra for a url so I can test.
Now Rick, I have no idea what the SMF login does so I don't know how easy or difficult it is to modify the CB login to do whatever extra it does. I am sure that someone could most likely figure this out and provide a solution.
I do know that alot of people have been posting about the lack of CB integration towards the SMF folks but they have not been very responsive - you can search over on their forum to see all of this.

Did the search for you - read this and this too .

Post edited by: nant, at: 2005/12/02 21:56

Post edited by: nant, at: 2005/12/02 22:07

Please Log in to join the conversation.

15 years 7 months ago #1222 by Manoxtra
nant wrote:

Ok - I have PMed Manoxtra for a url so I can test.
Now Rick, I have no idea what the SMF login does so I don't know how easy or difficult it is to modify the CB login to do whatever extra it does. I am sure that someone could most likely figure this out and provide a solution.
I do know that alot of people have been posting about the lack of CB integration towards the SMF folks but they have not been very responsive - you can search over on their forum to see all of this.

Did the search for you - read this and this too .

Post edited by: nant, at: 2005/12/02 21:56

Post edited by: nant, at: 2005/12/02 22:07


Nant, can you login, I have recieved an approval email and did not approve it... so can you login or not? B)

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.424 seconds

Facebook Twitter LinkedIn