Can not get CBSubs Email Integration to work

10 years 2 months ago #98576 by djackso1
My Setup:
Joomla 1.0.15
CB 1.2
CB Subs 1.0.1

I am trying to use the CBSubs email integration plugin to send a notice to an administrator when a new account is created.

I have the plugin installed and published. I have setup a plan and tested registering for the plan. The emails that I setup in the presentation tab are working as expected. I can even get a copy of these emails BCC'd to specified addresses. However, I am not receiving the emails that I configured in the Email integrations tab for this plan.

Any suggestions are appreciated. Please let me know if there is any other info I should provide to help diagnose what I am doing incorrectly. Thank you.
10 years 2 months ago #98598 by krileon
There are multiple types Activation, Renewal, Expired, Deactivation. Ensure you've configured the correct one. Activation will only send on first time activation of a subscription. Renewal will send on any subsequent renewals of the plan. Expired will send when the plan runs out of time. Deactivation will send when the plan is canceled, deleted, etc..

Subject or Body is required for the e-mail to send, must have one of the two.

You of course also need to have a To address. It does not automatically send to the user that purchased the subscription. This can be done by using a substitution for the To address such as .[email].


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
10 years 2 months ago #98612 by djackso1
krileon wrote:

There are multiple types Activation, Renewal, Expired, Deactivation. Ensure you've configured the correct one. Activation will only send on first time activation of a subscription. Renewal will send on any subsequent renewals of the plan. Expired will send when the plan runs out of time. Deactivation will send when the plan is canceled, deleted, etc..

Subject or Body is required for the e-mail to send, must have one of the two.

You of course also need to have a To address. It does not automatically send to the user that purchased the subscription. This can be done by using a substitution for the To address such as .[/quote] Thanks for the reply. I have everything configured you mentioned, still no emails. Any other suggestions are appreciated. Thank you.[email].


Thanks for the reply. I have everything configured you mentioned, still no emails.

Any other suggestions are appreciated. Thank you.
10 years 1 month ago #99180 by djackso1
djackso1 wrote:

krileon wrote:

There are multiple types Activation, Renewal, Expired, Deactivation. Ensure you've configured the correct one. Activation will only send on first time activation of a subscription. Renewal will send on any subsequent renewals of the plan. Expired will send when the plan runs out of time. Deactivation will send when the plan is canceled, deleted, etc..

Subject or Body is required for the e-mail to send, must have one of the two.

You of course also need to have a To address. It does not automatically send to the user that purchased the subscription. This can be done by using a substitution for the To address such as .[/quote] Thanks for the reply. I have everything configured you mentioned, still no emails. Any other suggestions are appreciated. Thank you.[/quote] Anyone else using the CBSubs Email plugin successfully with a setup similar to this: Joomla 1.0.15 CB 1.2 CB Subs 1.0.1 The emails that are sent as part of the base package of CBSubs are working as expected, but nothing from the plugin. I'm stumped and appreciate any suggestions anyone has. Thank you.[email].


Thanks for the reply. I have everything configured you mentioned, still no emails.

Any other suggestions are appreciated. Thank you.


Anyone else using the CBSubs Email plugin successfully with a setup similar to this:

Joomla 1.0.15
CB 1.2
CB Subs 1.0.1

The emails that are sent as part of the base package of CBSubs are working as expected, but nothing from the plugin. I'm stumped and appreciate any suggestions anyone has. Thank you.
10 years 1 month ago #99293 by krileon
I've tested all cases with my localhost and all e-mails have passed through the system fine. Check to ensure your e-mail is setup in Joomla properly or you've provided valid information in the e-mail plugins params for the e-mails to send (correct e-mail addres?).

Is this for subscribing at profile, backend, or registration?

Post edited by: krileon, at: 2009/05/19 21:50


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
10 years 1 month ago #99372 by djackso1
krileon wrote:

I've tested all cases with my localhost and all e-mails have passed through the system fine. Check to ensure your e-mail is setup in Joomla properly or you've provided valid information in the e-mail plugins params for the e-mails to send (correct e-mail addres?).

Is this for subscribing at profile, backend, or registration?

Post edited by: krileon, at: 2009/05/19 21:50


I wish it was an incorrect email address on my part;) As embarrassing as that would be at least I would know how to fix it.

I have configured the email plugin to send notices upon user registration (frontend), renewal (frontend), expiration and deactivation. Its hard for me to diagnose why they are not getting through, because the rest of the email triggers are working on my setup. I can even get the built-in emails from CBSubs to work. My issues seem to be isolated to the plugin.

What are my options for further support on this issue? I can't use CBSubs without the ability to send customized email notices to an admin upon registration, renewal and expiration. I appreciate any options you may know of. Thanks.
Moderators: beatnantkrileon
Time to create page: 0.402 seconds
Facebook Twitter Google LinkedIn