Error after upgrading groupjive

7 years 4 months ago #193620 by krileon
You must upgrade all of GJ 2.5 that you're using. You can't install just GJ 2.5 then use GJ 2.4 integration. The API was extended so GJ 2.4 integrations will cause errors as you've experienced. Uninstalling GJ will cause you to lose all your configuration, but the database will remain (so your categories, groups, etc.. will remain).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
7 years 4 months ago - 7 years 4 months ago #193905 by IAAF
I tried to add this post to another but now it looks like all the responses are to my post which they are not. I am therefore creating a new post and this one can be deleted. I apologize for this but don't understand how all these older responses got attached to my post :(

I just upgraded to CB 1.8, cbgallery, cbfbc, cbprofile book and cbtwc (2.5), mod_cbgroupjive_J17 (since I'm using Joomla_1.7). I tried to update every int, mod & plugin that was available for groupjive - but only ran into problem with the jivefile. When I tried to install the int_cbgroupjivefile_25 I received the following error:
=============================================
Not Acceptable

An appropriate representation of the requested resource /j16/administrator/index.php could not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
=============================================
after finishing all the installs (over the previous versions) I was able to go to my profile from front end and see the groups I had previously created. When I went to click on any of them to open, I then received this error:

Fatal error: Call to a member function get() on a non-object in <span>/</span>home<span>/</span>xxx/public_html/components/com_comprofiler/plugin/user/plug_cbgroupjive/plugins/cbgroupjivefile/cbgroupjivefile.php on line 41

is there any fix for this - looks like others have having similar problems with install of this file.
Moderators: beatnantkrileon
Time to create page: 0.380 seconds
Facebook Twitter Google LinkedIn