[SOLVED] CB 1.3+ - Can't create categories or groups

8 years 5 months ago #153747 by krileon

<input type="hidden" name="id" value="<?php echo (int) $row->id; ?>" />
<input type="hidden" name="id" value="<?php echo ( $row->id ? (int) $row->id : null ); ?>" />
<input type="hidden" name="task" value="" />

This is not correct, you have 2 ID fields. This would likely be your problem. Please review my fix on page 1 and apply as instructed. Please note it says FROM and then TO; you're doing a replacement and not an addition (which you've done above).

Have confirmed the fixes on page 1 resolve the issue with Categories and Groups.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
8 years 5 months ago #153825 by dmlund
OK, thanks for the quick response, but I have now done that and verified it again that I have only the one correct line on 357 and have saved. I unfortunately still have the same problem. I cannot create groups on the back end. I can create a group on the front end, it shows up on the back end, but I cannot publish it or change and save on the back end. I can delete it on the back end, but not create a group on the back end. If you would like to have me send a copy of the php file, let me know, but I believe it is right.
8 years 5 months ago #153854 by krileon
Please enable debug mode and maximum error reporting before attempting to save your group to see if there is any sort of error happening in backend. The above fix is confirmed working and can not duplicate your issue (once fix is applied).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
8 years 5 months ago #154073 by dmlund
Got it fixed. Turning on debug and max error only produced SQL activities that didn't seem to give me any insight. I went ahead and uninstalled both the component and CB plugin, made sure the groupjive administrator component directory was gone, then re-installed both and applied the changes to line 214 & 357 and we were working from that point on. Sorry to be a pain about this, but don't seem to have an answer for why my install was a problem, but good to go now. Thanks.
8 years 4 months ago #154737 by jerryLee
Wish you would have forwarded this to me when you commented about me posting it without searching, you would have saved me a lot of money and time. So is it safe to assume group jive is working correctly? I am building a social network for someone that has the potential of being huge, and I don't want it to fall apart when it get's busy.
thanks
8 years 4 months ago #154892 by krileon

jerryLee wrote: Wish you would have forwarded this to me when you commented about me posting it without searching, you would have saved me a lot of money and time. So is it safe to assume group jive is working correctly? I am building a social network for someone that has the potential of being huge, and I don't want it to fall apart when it get's busy.
thanks

I did.

www.joomlapolis.com/forum/103-groupjive/154443-group-jive-will-not-create-new-groups-or-category#154448


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: rebreanu
Moderators: beatnantkrileon
Time to create page: 0.394 seconds
Facebook Twitter Google LinkedIn