[SOLVED] CB 1.3+ - Can't create categories or groups

8 years 9 months ago - 8 years 6 months ago #147971 by dafunks
Hello,

I have CB 1.3 installed and GroupJive 1.8 as well as the plugin.

When I attempt to create a category in groupJive I get a success message but no category appears in the category listing. I have checked the database and there are no category entries.

Is this known issue with GroupJive?

Looking at firebug I see no javascript errors. The post data looks correct and is posted to index2.php.

Any help would be appreciated.

Thanks!

Post edited by: dafunks, at: 2010/12/07 07:48

Post edited by: krileon, at: 2010/12/08 21:16

Post edited by: krileon, at: 2010/12/20 16:04
8 years 9 months ago #148007 by mjriding
Interesting... I just posted this same exact problem. I found this happens with CB 1.3, not 1.23.

I believe the database structure must be slightly different or the function in CB is not returning the right values.... but, nonetheless, this is a bug.

I'm hoping there's a fix soon as I'm now dead in the water.

Mike
8 years 9 months ago #148029 by krileon
GJ doesn't have any relation to CB aside for some API usage. Creating categories or groups is not dependent on CB. Are you able to create categories/groups in backend? Do you have debug mode and maximum error reporting configured in Joomla global configuration? If not, please do so and duplicate the issue. Any on-screen errors? Any errors is server error log? Something must be stopping the query from completing its insert. GJ 1.8 is end-of-life and likely will not receive further updates until GJ 2.0 is released (soon) at which point 1.8 would be removed.

Post edited by: krileon, at: 2010/12/07 21:19


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
8 years 9 months ago #148067 by dafunks
Hello again,

Thanks for posting.


I am unable to create categories through the backend and cannot test group creation as you need a category first :P

I notice no errors with debugging enabled. There are also no errors in the Apache error log or mysql log.

Should I be able to see the query listed in the debug information once I have clicked "Save" on the category creation page?

Any further help you can provide would be greatly appreciated.

Perhaps I have missed some simple configuration requirements for groupJive.

Thanks again!

Post edited by: dafunks, at: 2010/12/08 03:17

*** I can confirm that installing cb 1.3 breaks groupJive. I installed a separate joomla site on the same configuration as my other broken site. GroupJive works with cb 1.2.3 installed (I was able to create categories). After upgrading to CB 1.3 I can no longer create categories in groupJive.

Post edited by: dafunks, at: 2010/12/08 05:01
8 years 9 months ago #148117 by pervalidus
I am also experiencing the same problem and cannot create categories in the backend using groupjive. I am running GJ 1.8.1 and CB 1.3. I checked my weblogs and no errors.
8 years 9 months ago #148125 by krileon
Was able to confirm your issue. This can be fixed with the below modification.

IN: administrator/components/com_groupjive/admin.groupjive.html.php
ON: Line 214
FROM:
[code:1]
<input type="hidden" name="id" value="<?php echo (int) $row->id; ?>" />
[/code:1]
TO:
[code:1]
<input type="hidden" name="id" value="<?php echo ( $row->id ? (int) $row->id : null ); ?>" />
[/code:1]

You should also make this change at the following location for groups.

ON: Line 357
FROM:
[code:1]
<input type="hidden" name="id" value="<?php echo (int) $row->id; ?>" />
[/code:1]
TO:
[code:1]
<input type="hidden" name="id" value="<?php echo ( $row->id ? (int) $row->id : null ); ?>" />
[/code:1]


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: cmadrigal, jayaseelan, justmebg, zedian, esenric, wolly.ireland
Moderators: beatnantkrileon
Time to create page: 0.395 seconds
Facebook Twitter Google LinkedIn