[#1291] Required fields still required when hidden

8 years 11 months ago #137731 by softforge
Congratulations on CB 1.2.3! I hope it has the required changes for CBSubs 1.1 to fix this issue.

Is there any way to test CBSubs 1.1 RC1 to confirm this has been fixed before it's public release?

Many thanks.

If you like our plugins, please consider writing a review on the Joomla Extension Directory or the Community Builder Directory ...
8 years 11 months ago #137734 by nant
softforge wrote:

Congratulations on CB 1.2.3! I hope it has the required changes for CBSubs 1.1 to fix this issue.

Is there any way to test CBSubs 1.1 RC1 to confirm this has been fixed before it's public release?

Many thanks.


Yes its fixed.

Just send me a PM if you want to join the test team.
8 years 9 months ago #141158 by scharles
Just read through this thread. I'm having the same issue. I want to create a plan based on my main form that only shows one field (Email Address) and nothing else. However, my form is still Showing the Verify Password field, and still enforcing hidden required fields.

Is there a patch for this? I have a deployment in two weeks that depends on this working, and I purchased the licensing for this in good faith.

If there is an un-released patch, I'll be happy to test it on my site. Please private message me.

Thanks!

Steve
8 years 9 months ago #141266 by softforge
Unfortunately there is no fix for this bug yet. I have 7 sites which this impacts so I am making sure that doesn't get forgotten and I have been assured that us will be fixed for the next release:

beat wrote:

Tagged the IE6+IE7 issue of 1.1 RC2 as #1917 for investigation.

Thank you for reporting. We support IE6+7 front-end, so this needs to be fixed for stable.


If you like our plugins, please consider writing a review on the Joomla Extension Directory or the Community Builder Directory ...
8 years 8 months ago #142430 by softforge
scharles wrote:

Is there a patch for this? I have a deployment in two weeks that depends on this working, and I purchased the licensing for this in good faith. If there is an un-released patch, I'll be happy to test it on my site.

I have managed to find a fix for the IE6/IE7 always required bug. Open the following file:

[code:1]components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/js/cbpaidsubscriptions.min.js[/code:1]

And replace mosreq with mosReq and the required fields should now work correctly in all IEs.

I hope this helps until the next version of CBSubs is released. :)

If you like our plugins, please consider writing a review on the Joomla Extension Directory or the Community Builder Directory ...
8 years 8 months ago #143279 by jhaines
Works for me! Thanks for the fix!

(I'm using IE7 with J1.5.20 / CB1.2.3 / CBSubs1.0.3)

Julian
Moderators: beatnantkrileon
Time to create page: 0.689 seconds
Facebook Twitter Google LinkedIn