URL plugin over https

10 years 9 months ago #112758 by amazeika
URL plugin over https was created by amazeika
Is there a limitation for the URL plugin while using SSL?.

I'm using the POST method with the https prefix in the path and the plugin is not firing anymore since yesterday (when I activated SSL over the site).

Arunas

Post edited by: krileon, at: 2009/10/02 15:27

Post edited by: amazeika, at: 2009/10/05 09:37

Arunas Mazeika
WeXtend.com - Professional development for Joomla!.

Please Log in to join the conversation.

10 years 9 months ago #112763 by krileon
Replied by krileon on topic Re:URL plugin over https
amazeika wrote:

Is there a limitation for the URL plugin while using SSL?.

I'm using the POST method with the https prefix in the path and the plugin is not firing anymore since yesterday (when I activated SSL over the site).

Arunas


SSL shouldn't affect it, but it's possible it has. Check server error logs to see if any error was reported. You can also check CBSubs History for some errors.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

10 years 9 months ago #112774 by amazeika
Replied by amazeika on topic Re:URL plugin over https
I encourage you to investigate this since I confirm that the plugin is not calling the php script.

There is no trace of errors on the server logs or the cbsubs logs that point to this issue.

Arunas

Arunas Mazeika
WeXtend.com - Professional development for Joomla!.

Please Log in to join the conversation.

10 years 9 months ago #112901 by amazeika
Replied by amazeika on topic Re:URL plugin over https
I just visualized some of my Apache access logs and it seems that you are always making the request over the 80 port no matter what. This was causing a redirection loop on my case.

I have a rewrite rule over the 80 port that redirects all connections to this port to my secured port.

What I did to temporary solve the problem, is to add a rewrite condition over the requested file to avoid a redirection over the secured area.

You need to fix this in order to be able to send the POST/GET request to any desired port, perhaps by parsing the given url as http:://thehost:theport/thefile.php.

Hope this helps.

Arunas Mazeika
WeXtend.com - Professional development for Joomla!.

Please Log in to join the conversation.

10 years 9 months ago #112908 by krileon
Replied by krileon on topic Re:URL plugin over https
Your changes will cause all plugins which utilize snoopy to fail. Default port is 80. Edit Snoopy.class.php in administrator/components/com_comprofiler/ and change the default port from 80 to whatever you need. The issue however isn't the port, port 80 will work fine for you or any host for that matter, but you're rewriting away from port 80 and this is breaking the request. Your exception in the rewrite should suffice.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

10 years 9 months ago #112911 by amazeika
Replied by amazeika on topic Re:URL plugin over https
Thanks krileon,

Changing the port in the config will solve the problem. However, keep in mind that redirecting from the 80 port to the secured port (443 by default) is a very common practice when using SSL.

People that are not aware of this Snoopy thing will have a hard time trying to figure out the problem, and I totally disagree with you when you tell me that the problem is not the port 80. I could be using another port, 80 is just the default port.

My solution works but as you pointed out, any app that makes use of this library will fail, so it's better to set the right port in the library config file.

Post edited by: amazeika, at: 2009/10/02 15:39

Arunas Mazeika
WeXtend.com - Professional development for Joomla!.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.426 seconds

Facebook Twitter LinkedIn