[SOLVED] strange error prevents payment

11 years 2 months ago #119074 by beat
Replied by beat on topic Re:strange error prevents payment
michaedt wrote:

Yes this solved the problem! Thanks again.
For those who might have a similar problem, it turns out that the problem is rooted in the JCE editor (I was using version 157, which I think is the most recent). It inserts the following code every time you open an article (or plugin)...anything that uses JCE:
[code:1]<input id="gwProxy" type="hidden" /><!--Session data--><input onclick="jsCall();" id="jsProxy" type="hidden" />
<div id="refHTML"></div>[/code:1]

If you open that item more than once, it inserts it again and again, which is what happened to me. Every time I examined the plugin (which didn't have any visible text), it added another line of this code. I turned off my editor and deleted the code from the sub component per Beat's instructions (and ALL of my articles, modules, and plugins).

In short, beware if you use JCE. My clients love it, but I'll have to figure out what is causing the odd behavior.

Post edited by: michaedt, at: 2009/12/13 18:24


Thanks a lot for noting the issue for others.

That seems to me a pretty serious bug. Could you please report the bug to JCE team and paste link of the error report in here so others can follow resolution ?

Many thanks again,

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

11 years 2 months ago #119082 by michaedt
Replied by michaedt on topic Re:[SOLVED] strange error prevents payment
The problem may not be JCE related, but a Firefox extension that causes problems with all WYSIWYG editors.

According to the following forum post: forums.bvcommerce.com/default.aspx?m=63774&f=78&p=1 , the plugin "Browser Highlighter" adds this code.

I was, in fact, using this plugin. I deleted it and I no longer see the problem. I'll have to test it more extensively before I can be certain, but it seems to fit.

I'll double check with the folks at JCE and post back if the problem is rooted in JCE.

Post edited by: michaedt, at: 2009/12/13 21:52

Please Log in to join the conversation.

11 years 2 months ago #119084 by beat
Cool, thanks for researching and sharing B)

Really appreciated :)

Karma up ;)

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

11 years 2 months ago #119085 by beat
Btw: That means that you should be checking the html code of all the html editors settings and articles that you saved with that browser-extension enabled... :S

I'm thinking at CB fields, tabs and CBSubs global settings and plans settings...quite a few places....

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

11 years 2 months ago #119088 by michaedt
Replied by michaedt on topic Re:[SOLVED] strange error prevents payment
Yes, thank you. I did that earlier and found several instances of the bad code and deleted them all.

Also, after more testing, I'm not convinced that the FF plugin "Browser Highlighter" was causing the problem.

I don't need the WYSIWYG editor for this site, so it's not a problem to leave it off. However, expect a post back from me after I learn more from the folks at JCE (because I need it for other clients). I'll test with TinyMCE and others to determine if it is the content editor or something else in my browser (I'll switch browsers too). Give me a day or so to test various configurations and I'll let you know what I discover.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.434 seconds

Facebook Twitter LinkedIn