[SOLVED] Plans page not listing Plans - backend

9 years 1 week ago #146863 by tto
Hello,

When I select the "Plans" menu link, it take longer time to load the "Plans" page than any other page in CBSubs, CB or any other in joomla backend.

Also, when the "Plans" page show, it doesn't list the plans in the table as it should, I have to select the "plan" I want from the "Filter" above to show it.

What can be the problem?





Post edited by: tto, at: 2010/11/23 15:37

Post edited by: krileon, at: 2010/12/13 21:37

Regards,

Tariq
Attachments:
9 years 1 week ago #146893 by krileon
Please enable debug mode and maximum error reporting within Joomla global configuration. More then likely there's a fatal error. Probably related to memory usage (try increasing PHP memory limit).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 1 week ago #147047 by tto
Hello Krileon,

When I enabled the error mode, I received the fallowing error:


start
500 - An error has occurred.

JDatabaseMySQL::query: 126 - Incorrect key file for table '/tmp/#sql_100f_0.MYI'; try to repair it SQL=SELECT a.`id`, a.`name`, a.`alias`, a.`exclusive`, a.`rate`, a.`validity`, IF( ( a.`recurring_max_times` = 0 ), 'unlimited', a.`recurring_max_times` ) AS `recurring_max`, a.`first_rate`, a.`first_validity`, a.`ordering`, a.`published`, a.`allow_newsubscriptions`, a.`allow_registration`, a.`allow_upgrade_to_this`, a.`access`, a.`default`, a.`usergroup`, IF( ( a.`owner` = 0 ), 'System', c.`username` ) AS `owner_name`, COUNT( DISTINCT d.`id` ) AS `change_logs`, COUNT( DISTINCT e.`id` ) AS `subscribers`, a.`currency`, a.`cssclass`, a.`description`, b.`id` AS `parent` FROM `jos_cbsubs_plans` AS a LEFT JOIN `jos_cbsubs_plans` AS b ON b.`id` = a.`parent` LEFT JOIN `jos_users` AS c ON c.`id` = a.`owner` LEFT JOIN `jos_cbsubs_history` AS d ON d.`table_name` = '#__cbsubs_plans' AND d.`table_key_id` = a.`id` LEFT JOIN `jos_cbsubs_subscriptions` AS e ON e.`plan_id` = a.`id` GROUP BY a.`id` ORDER BY IF( ISNULL( b.`ordering` ) , a.`ordering`, b.`ordering` ) ASC, IF( ISNULL( b.`ordering` ) , a.`ordering`, ( 11000 + a.`ordering` ) ) ASC, a.`ordering` ASC, b.`ordering` ASC, a.`ordering` LIMIT 20

end

Also below the above error was a "Call stack" table with 23 rows.

What do you recommend?

Thanks,

Regards,

Tariq
9 years 1 week ago #147063 by beat
tto wrote:


start
500 - An error has occurred.

JDatabaseMySQL::query: 126 - Incorrect key file for table '/tmp/#sql_100f_0.MYI'; try to repair it ....

What do you recommend?

Thanks,



I actually strongly recommend to read the error message :)

I do read at begin of the error message:

Incorrect key file for table '/tmp/#sql_100f_0.MYI'; try to repair it


I think that's a pretty clear error message... ;)

Use e.g. PhpMyAdmin to check and REPAIR your database tables. If that fails (unprobable if your database is set up correctly with journaling), you would need to delete your database and restore from backup. Or... ask your hoster to do this for you, as such errors are usually due to system crashes or other crashes on the server.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
9 years 1 week ago #147105 by tto
Hello,

I checked with cpanel & phpmyadmin, no errors at all!

I also had a professional programmer to check, no errors in the database, everything is fine.

What can I do?

Regards,

Tariq
9 years 6 days ago #147140 by krileon

What can I do?

Please upgrade to CB 1.3 and CBSubs 1.1 as issue maybe resolved already. If not, please do as Beat has instructed in the previous post as you've an error in your database concerning that table.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.476 seconds
Facebook Twitter Google LinkedIn