Fatal Error in Facebook Connect when using Invitex

9 years 5 months ago #164508 by vamarra
Hi,
I recently installed Invitex on one of my sites where I also have CB and CB Facebook Connect v 1.3 installed.

When I go to the Invitex menu item I created, I get the following error message:

Fatal error: Call to undefined method facebook::getUser() in public_html/components/com_comprofiler/plugin/user/plug_cbfacebookconnect/cb.facebookconnect.php on line 694

Note that I do not have this problem with invitex on other sites I use it on where I do not have CB Facebook Connect installed.

Any idea what could be causing this problem?

Thanks.

Please Log in to join the conversation.

9 years 5 months ago #164610 by krileon
Function getUser (line 705) is defined directly below function getUserID, which is where the error is occurring. "facebook::getUser()", this is not correct however. The usage is not by reference, but object oriented using "$facebook->getUser();". Was FBC altered in any way?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 5 months ago #164622 by vamarra
Thanks for your response. I haven't altered FBC in any way. Should I try changing the code as you stated? Thanks.

Please Log in to join the conversation.

9 years 5 months ago - 9 years 5 months ago #164660 by krileon
Please reinstall FBC 1.3 as well as ensure you've absolutely no other Facebook extension installed as they will conflict. There's no code to alter, it's working perfectly fine as is. I've no idea why your install is trying to execute by reference instead of by object; some sort of optimization extension installed perhaps?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 5 months ago #164673 by vamarra
Okay, thanks, I will try reinstalling FBC 1.3 and will let you know what happens. It works fine in general, just only when I try to go to the invitex menu item I get that message. So I will see if reinstalling it fixes it. Thanks.

Please Log in to join the conversation.

9 years 4 months ago #165229 by vamarra
Hi, I tried this:

I uninstalled CB FBC 1.3 and went to the Invitex menu item, and I was able to view the Invitex component on the front end okay.

Then, I reinstalled CB FBC 1.3, and then when I went to the Invitex menu item on my front end I got the same error message as mentioned above.

I have CB FBC set up in "No Conflict" mode as well.

Any other ideas how I can fix this?

Thanks.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.421 seconds

Facebook Twitter LinkedIn