Resgistered Member menu items not showing when log

9 years 2 months ago - 9 years 2 months ago #169468 by CoachJohn
Hi, I am having an issue on my site.
I have some menu items, in the main menu, that are set to be visible to registered members.
When I log on as a member through the usual username password then the menu items shows.
If I sign in through the Facebook connect the registered menu items do not show.
Any ideas where I am going wrong?

Joomla 1.6.4 CB 1.4

http://eclipsepsychics.com/

Please Log in to join the conversation.

9 years 2 months ago #169490 by krileon
Please check the FBC user within user management and ensure they've an appropriate usergroup of Registered. Please also provide what version of FBC you're using.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 2 months ago #169537 by CoachJohn
Hi krileon,

The Facebook registered users have usergroup either registered or author.

FBC version CB Facebook Connect 1.4: A cb login authentication integration plugin for facebook.

Please Log in to join the conversation.

9 years 2 months ago #169600 by krileon
This is likely due to existing ACL issues with CB regarding Joomla 1.6. I can not duplicate your issue on next release of CB (internal for now) where ACL fixes have been applied. Appears will be resolved for next release.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 1 month ago - 9 years 1 month ago #173213 by SFx86
Same here on dev.lanzdorf.com: Users authenticating via fb wont see menu items with access level "registered" on CB 1.7 on J 1.7 with Facebook Connect 1.4. The user profile is created as "registered", though...


// edit:

(1) Rows created in joomlas user table don't differ from manualy created user records.
(2) Same behaviour with Twitter Connect 1.1 ...


// further:

(1) authorisedLevels() called on a user object of a "regular" registered member:
Array ( [0] => 1 [1] => 1 [2] => 2 )

(2) authorisedLevels() called on a user object logged in with fb connect:
Array ( [0] => 1 [1] => 1 )


// maybe related known issue:

[#26420] user access levels cache not updated when user added to a new group


// quick and dirty fix in core:

in /libraries/joomla/user/user.php:429 insert:
// giving up trying to post the code since:

editing this post I often get
501: Method Not Implemented
POST to /forum/post not supported.
How about S U P P O R T ?

Please Log in to join the conversation.

9 years 1 month ago #173290 by krileon


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.489 seconds

Facebook Twitter LinkedIn