[SOLVED] Please complete the username and password fields

8 years 3 months ago - 8 years 2 months ago #172705 by Development
Hi,

When i try to use the Facebook or Twitter connect plugin for CB i get the following error:

"Please complete the username and password fields"

I found these posts:
www.joomlapolis.com/forum/117-facebook-connect/147398-fb-connect-bug-username-a-password#147436
www.joomlapolis.com/forum/117-facebook-connect/169739-please-complete-the-username-and-password-fields

I tried those fixes but that didn't seem to work. Is it possible that these connect plugins dont work with some of the settings that CB provides?

I am using:
CB V1.4
Facebook Connect V1.3
Twitter Connect V1.1
Website is: www.drooog.nl (Website is Dutch but choose "Inloggen" in the top-right corner to check the login)
8 years 3 months ago #172804 by krileon
Please upgrade to CB 1.7 and FBC 1.4 then confirm if issue still present. This can happen if no "name" was returned from Facebook; without it it is impossible to create the user as there's no information to go off.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
8 years 3 months ago #172862 by Development
Hi,

Thanx for your reply. I tried updating to FBC1.4 dut that didnt work. It seemed that the solution was simpeler (after 4 hours of searching).

At some point I deleted the user in de Joomla users manager to cleanup the website. The problem was that the user was still in the CB table but missing the required data from the jos_users table. When the Facebook and Twitter fetched the userdata they were missing the required username and password from the jos_users table.

I cleaned up the CB table with the "Synchronise users" tools (Community builder -> Tools) and recreated my user with the Facebook connect plugin, which was working well all this time.
The following user(s) said Thank You: dereks1961, mattwhi, adamr_z, Shawn.Jewell
7 years 7 months ago #196404 by mattwhi
Thanks for this solution, not only has this fixed my FB Connect, but I was also getting errors "JUser: :_load: Unable to load user with ID: 62" which I think this simple fix has also solved!
Moderators: beatnantkrileon
Time to create page: 0.484 seconds
Facebook Twitter Google LinkedIn