Redirection Issue

7 years 10 months ago #187136 by krileon
FBC doesn't use CBs redirects. It uses its own redirects. Is it redirecting to index.php on every login or just first login when attempting to register with FBC?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
7 years 10 months ago #187172 by lebellegardien
yes it's redirect to index.php on registration, first login and login.

I tried CB Connect 2.1.0 and it's the same. I disabled SH404SEF but it's the same. And what is strange is that if logged me with cb fields login and password, redirection works fine but not with facebook.

You can try on my website : www.lebellegardien.com

cheers
7 years 10 months ago #187179 by lebellegardien
And now with CB Connect 2.1.0 or FBConnect 1.8 don't ask me If I'm agree to share Facebook fields with my website the first time I connect with Facebook. And it doesn't get avatar picture from facebook too.
7 years 10 months ago #187185 by lebellegardien
I don't know what I made but redirection now works with CB Connect. But avatar picture doesn't get from facebook and the permission facebook windows doesn't appear when I log the first time.
7 years 10 months ago #187244 by krileon

But avatar picture doesn't get from facebook

It's only synchronized on first time login (registration) with Facebook. If performing a subsequent login or linking to an existing user it will not synchronize such information.

the permission facebook windows doesn't appear when I log the first time.

You already approved the application, probably when using FBC.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
7 years 10 months ago #187270 by arnaud_blain
It's only synchronized on first time login (registration) with Facebook. If performing a subsequent login or linking to an existing user it will not synchronize such information.

Yes I know, I delete the user and login me with facebook but it doesn't get picture. I also add Avatar rule in CB Connect Field to get (even if it says that it's better to didn't override it) but it's the same.

the permission facebook windows doesn't appear when I log the first time.
I was talking about each user that login for the first time with facebook and now I can't see this Facebook window preventing the user if he's ok to share my fields.
Moderators: beatnantkrileon
Time to create page: 0.432 seconds
Facebook Twitter Google LinkedIn