CB Captcha + CB 1.2.3 sporadic problems

13 years 4 months ago #147875 by krileon
Replied by krileon on topic Re:CB Captcha + CB 1.2.3 sporadic problems
We've been investigating this issue and just can't seam to find a cause. We've made multiple test releases and it seams to be a problem with the GD library related to users host not being properly compiled. Drawing an image in GD is failing erratically.

Using 3rd party plugins that draw the captcha from an alternative source work because the image is fed to you from a 3rd party. Our plugin uses your own server and library to generate the image and with a faulty GD library it will cause the image to fail.

Best I can suggest is to re-compile your GD and PHP.

www.php.net/manual/en/image.installation.php


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

13 years 4 months ago #147918 by gianpietro
Replied by gianpietro on topic Re:CB Captcha + CB 1.2.3 sporadic problems
Hi krileon,

Thanks for your reply. I will try to recompile PHP, will take me some time because I'm not familiar with manual compilations. Already tried apt-get uninstall and then install but no luck :(

Just one question: does this captcha plugin require some GM function which is not installed by default on Ubuntu using apt-get? I read that some functions can be installed only with manual compilations.
I guess not, because the image is working most of the time.

thanks,
Gianpietro

Please Log in to join the conversation.

13 years 4 months ago #148113 by krileon
Replied by krileon on topic Re:CB Captcha + CB 1.2.3 sporadic problems
Not sure, are avatar uploads and such working at all points in time with GD selected as the library in CB configuration? Doing some research have found the following.

If the code does not appear on the image it usually means one of two things. Either the path to the TTF file is incorrect or there is a problem displaying transparent text in the PHP and GD version you are using.


I can't think of anything else that would cause issue to only SOMETIMES occur. It could be possible the captcha code is failing to be stored/passed to the plugin properly.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

13 years 4 months ago #148174 by gianpietro
Replied by gianpietro on topic Re:CB Captcha + CB 1.2.3 sporadic problems
It seems that the link is being passed fine, but then GD fails to draw the letters only sometimes.

I obtained the image info from firefox and I can see the right link, then I copy the specific link and load it in a separate tab and it fails only sporadically when refreshing it. Take a look at the attachments.

So we can conclude that this is a php/gd intermittent problem? any ideas on how to debug it?

Thanks!
Gianpietro



Post edited by: gianpietro, at: 2010/12/09 01:54
Attachments:

Please Log in to join the conversation.

13 years 4 months ago #148248 by krileon
Replied by krileon on topic Re:CB Captcha + CB 1.2.3 sporadic problems

So we can conclude that this is a php/gd intermittent problem?

Same conclusion we came to.

any ideas on how to debug it?

Not really, best approach is to have PHP recompiled with latest GD if on linux/mac. If on windows just update the GD module.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

13 years 3 months ago #151293 by malles
Replied by malles on topic Re:CB Captcha + CB 1.2.3 sporadic problems
Hi, I have the exact same problem on two of my CB-sites, on two different servers...
Site 1:
- PHP Version 5.2.14
Site 2:
- PHP Version 5.3.2-1ubuntu4.7
Both:
- CB Version 1.3.1
- Joomla Version 1.5.22
- Problem is that sometimes the captcha image shows no letters (image appears but with no letters on it), then I refresh the page and they appear.
- Link to test: not online yet (keep pressing F5 and sometimes you will not see the letters)
- There are no errors related to the plugin.
- Using SEF Advance 2008, but problem persists when disabling it.
- All is fresh install.
- Issue is present in Firefox and IE8 as far as I tested.
- Issue is present using GD2

Any news on how to fix this?

Thanks,
Matthijs

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.231 seconds

Facebook Twitter LinkedIn