new line in message is not working

8 years 2 months ago #163439 by cliffvt
Thank you so much Slabbi - have unpublished that one now. Appreciate your quick response.

Cliff
8 years 2 months ago #163467 by slabbi
btw I have a new version of that plugin in the SVN on Joomlacode.org (see sticky in uddeIM forum). The new version is Joomla 1.6 compatible (blocking of groups works and also user banning).

uddeIM & uddePF Development
Google+ profile: plus.google.com/u/0/b/117839921924782901705/
CB Language Workgroup
CB 3rd Party Developer
8 years 2 months ago #163673 by cliffvt

slabbi wrote: Plase ensure that the text containing the line breaks is quoted with "" (e.g. in the language file) and not '' otherwise PHP does not treat \r as a line break.


Slabbi

Despite my best efforts I cannot seem to figure out which language file this could be in. I tried the uddeim admin english.php but it's not there and I'm a bit lost - any pointers for me, please?

After the update I still get "r" at the end of every line (BUT ONLY IN THE WELCOME MESSAGE, not the header section) although the line breaks seem to work fine.. so I am a bit stuck. Example of welcome email:

Hi Penny Foxtrot,

Website Administrator has sent you the following private message at MYSITE site. Please log in to reply!

myweb.co.uk
__________________
Welcome Aboard Penny Foxtrot!

Hello Penny Foxtrot, Welcome to our members only website!r
r
We hope that you enjoy using the site and should you have any questions at all, please feel free to email abc@abc.co.ukat any time.r
r
Kind regardsr
r
Web Administrator


Another thing you may need to know is that Notification method in CB Autowelcome is set as PMS only, then Uddeim is set for PMS Notification as email - so not sure whether this is what is causing the problem...

It also seems to loose the space between the email address in the text and the next word for some reason in the process as well : from above example:

...abc@abc.co.ukat any...


Cheers

Cliff
8 years 2 months ago #163680 by slabbi
Please check the language file of the Autowelcome plugin (maybe the text is part of the CB language file). I do not use the Autowelcome plugin so I cannot help you here.

uddeIM & uddePF Development
Google+ profile: plus.google.com/u/0/b/117839921924782901705/
CB Language Workgroup
CB 3rd Party Developer
7 years 7 months ago #184860 by RoobarbnCustard
I'm seeing this problem and I've followed suggestions in this thread but no luck.

Versions:
Joomla 1.7.3
CB 1.7.1
AutoWelcome 1.2
uddeIM 2.5
uddeIM PMS CB Plugin 2.5

With mypms plugin, the notification email has an r at each line break
With uddeIM plugin I get rn at each line break in both the email and the message.

I can workaround by not including the message text in the email, but I'd rather have it included.

Anybody got any other ideas?

Thanks.
7 years 7 months ago #184861 by slabbi
The Text "Welcome to our members only website..." in somewhere defined. Please check this file and ensure that the text is enclosed in double quotes ("), not single quotes (').

When single quotes are used escape codes are not evaluated.

uddeIM & uddePF Development
Google+ profile: plus.google.com/u/0/b/117839921924782901705/
CB Language Workgroup
CB 3rd Party Developer
Moderators: beatnantkrileon
Time to create page: 0.378 seconds
Facebook Twitter Google LinkedIn