User can't set own privacy to invisible fields

9 years 1 month ago #137531 by serwiswww.pl
Hello

I think I found a bug. When a field is not visible by default in the user profile, the user can not set the privacy for that field.

I think that if I allow the user to change privacy in a given field, even if the field is invisible by default in the profile, the user should be able, if necessary, to change this privacy.

Best Regards
Piotr

PS: Sorry for my English!
9 years 1 month ago #137541 by krileon
If a field is set to not display on profile then it will not have privacy controls. You need to ensure the field is set to display on profiler either on a single line or two line display. There is no workaround for this, CBs core takes priority and will not display the field if configured not to display.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 1 month ago #137564 by serwiswww.pl
OK, I understand. Is it possible to set the default privacy to these fields?

Best Regards
Piotr

PS: Sorry for my English!
9 years 1 month ago #137672 by krileon

OK, I understand. Is it possible to set the default privacy to these fields?

No, we've a feature ticket in our system to have something such as default privacy added to a future release.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
7 years 1 month ago #204089 by AchLive
I'm experiencing the same problem. For this case the solution may be forge.joomlapolis.com/issues/2168 patch?
If the solution to the problem is that all files are installed (2168a.patch + 2168b.patch + 2168a_rev1.patch) or is it sufficient to install the latest? How do I install a patch?
I installed the latest version 1.3
Thanks and sorry for my English.
Moderators: beatnantkrileon
Time to create page: 0.401 seconds
Facebook Twitter Google LinkedIn