Privacy add-on not showing up

11 years 2 weeks ago #192770 by davidjoomla11
Replied by davidjoomla11 on topic Re: Privacy add-on not showing up
hi nant, i am facing a similar issue. the additional privacy parameter at the backend is ok.

At the front end, it appears only for tabs. It doesn't work for fields. Please help.

Thanks.

Please Log in to join the conversation.

11 years 2 weeks ago #192777 by nant
Replied by nant on topic Re: Privacy add-on not showing up

davidjoomla11 wrote: hi nant, i am facing a similar issue. the additional privacy parameter at the backend is ok.

At the front end, it appears only for tabs. It doesn't work for fields. Please help.

Thanks.


Here is what I did to test:

1. Installed latest CB Privacy plugin v. 1.3 on a CB 1.8 / J 2.5.1 site
2. Published plugin
3. Created a new CB text field
4. Set Privacy configuration level for this field (right column parameters) to User can control privacy

Once I do above, if I edit my profile I see that I can control the privacy of the field.

Please Log in to join the conversation.

11 years 2 weeks ago #193093 by davidjoomla11
Replied by davidjoomla11 on topic Re: Privacy add-on not showing up
hi Nick,

After spending 2 days, I found the problem. The culprit is CBSubs protection. Once this plugin is disabled, the privacy tab for field shows up.

I don't know to be happy or upset after taking so long to diagnose and discover this is the cause. Is it stated somewhere that CBSubs protection will render Privacy for fields useless? I need to use both so what's the next step? Thanks

Please Log in to join the conversation.

11 years 2 weeks ago #193095 by beat
Replied by beat on topic Re: Privacy add-on not showing up
Hm, that's strange.

In which order did you have these plugins in the plugins manager in the backend ?

Can you please try to change the ordering of these 2 plugins in the CB plugins manager, so they load in the reverse order ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
The following user(s) said Thank You: davidjoomla11

Please Log in to join the conversation.

11 years 2 weeks ago - 11 years 2 weeks ago #193189 by davidjoomla11
Replied by davidjoomla11 on topic Re: Privacy add-on not showing up
hi beat,

I followed your step and it works perfectly now. Is the order supposed to matter and are CBSubs users supposed to know? I hope others don't have to go through what i did. Thanks!

Btw, the font size of the "Visible on profile" is almost doubled that of the font size for the field values! How can the font size of the former be changed?

Please Log in to join the conversation.

11 years 2 weeks ago #193226 by nant
Replied by nant on topic Re: Privacy add-on not showing up

davidjoomla11 wrote: hi beat,

I followed your step and it works perfectly now. Is the order supposed to matter and are CBSubs users supposed to know? I hope others don't have to go through what i did. Thanks!

Btw, the font size of the "Visible on profile" is almost doubled that of the font size for the field values! How can the font size of the former be changed?


Hmm, so if CBSUbs plugin is listed first then privacy plugin issue happens?

Or other way around?

What versions of Joomla, CB, CBSUbs, Privacy?

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.391 seconds

Facebook Twitter LinkedIn