Nightly build of January 11th, 2021

1 year 1 week ago #322534 by beat
Replied by beat on topic Nightly build of January 11th, 2021

cez wrote: HI,
What if the CB configuration was basically based on the CB Quickstart plugin? Will pressing Quickstart / Reinstall in Plugin Management help in restoring main settings (or part?)?

thx


Yes indeed, good point, updating the advisory above in first post.

One of the many steps in which we missed this bug in our quality assurance procedures (that btw didn't miss any annoying bug in well over 10 years) is that we upgraded our demo site that is using CB Quickstart by updating CB Quickstart too, which re-configured fine the settings!

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

1 year 1 week ago #322536 by beat
Replied by beat on topic Nightly build of January 11th, 2021

kommid wrote: I tried to install it trhough joomla:
001_pkg_communitybuilder_2.4.7+build.2021.01.04.15.02.57.e1fe54f7e.zip is being installed.
001_pkg_communitybuilder_2.4.7+build.2021.01.04.15.02.57.e1fe54f7e.zip failed to install! hide
500 - Internal Server Error


I could now reproduce and confirm this error when trying to downgrade in the Joomla extensions installer.

But a second try to install it through the Joomla installer then succeeds. Of course the re-configuration or configuration restore is still needed.

And the downgrade/reinstallation of the previous version through clicking the "Already installed" grey button works fine from first try.

I have an idea on the reason (old CB 2.4.7+build.2021.01.04.15.02.57.e1fe54f7e.zip installer not compatible with the new running CB library 2.4.7+build.2021.01.11.18.11.18.403e0c931.zip), but we need to dig to confirm. Anyway, just try installing twice from Joomla. Updating the advisory above accordingly in EDIT 4.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

1 year 1 week ago - 1 year 1 week ago #322537 by kondrich
Replied by kondrich on topic Nightly build of January 11th, 2021

beat wrote:

kommid wrote: I tried to install it trhough joomla:
001_pkg_communitybuilder_2.4.7+build.2021.01.04.15.02.57.e1fe54f7e.zip is being installed.
001_pkg_communitybuilder_2.4.7+build.2021.01.04.15.02.57.e1fe54f7e.zip failed to install! hide
500 - Internal Server Error


I could now reproduce and confirm this error when trying to downgrade in the Joomla extensions installer.

But a second try to install it through the Joomla installer then succeeds. Of course the re-configuration or configuration restore is still needed.

That's correct. A second downgrade try successfully downgrades. However, the member fileds are still empty.

Please Log in to join the conversation.

1 year 1 week ago - 1 year 1 week ago #322539 by beat
Replied by beat on topic Nightly build of January 11th, 2021

kondrich wrote:

beat wrote:

kommid wrote: I tried to install it trhough joomla:
001_pkg_communitybuilder_2.4.7+build.2021.01.04.15.02.57.e1fe54f7e.zip is being installed.
001_pkg_communitybuilder_2.4.7+build.2021.01.04.15.02.57.e1fe54f7e.zip failed to install! hide
500 - Internal Server Error


I could now reproduce and confirm this error when trying to downgrade in the Joomla extensions installer.

But a second try to install it through the Joomla installer then succeeds. Of course the re-configuration or configuration restore is still needed.

That's correct. A second downgrade try successfully downgrades. However, the member fileds are still empty.


After the 2nd downgrade install, either:

- go to CB Configuration, check the settings, and important, re-save the CB configuration. Do same for the core CB plugins (listed in first post of this thread) as well as for any CB plugins you would have upgraded same time or after installation of pkg_communitybuilder_2.4.7+build.2021.01.11.18.11.18.403e0c931

- or restore from recent backup of before pkg_communitybuilder_2.4.7+build.2021.01.11.18.11.18.403e0c931 installation the #__comprofiler_plugin table or params column of it for row id 1 (CB configuration) and the core CB plugins listed in first post of this thread as well as for any other plugins that you upgraded same time as CB or during the install of pkg_communitybuilder_2.4.7+build.2021.01.11.18.11.18.403e0c931 and then re-check and re-save your CB Configuration and same for core CB plugin's listed in the first post and of any plugins that you upgraded same time or during the installation time of pkg_communitybuilder_2.4.7+build.2021.01.11.18.11.18.403e0c931 .

If issue of empty member profiles persists, turn Joomla debug on in System / Global (joomla) configuration / System / Debug System, and see if there are any errors reported in the profile view ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

1 year 1 week ago #322540 by kommid
Replied by kommid on topic Nightly build of January 11th, 2021
seems to work: Second install was smooth, restored comprofiler_plugins table and everything seems to work.
Thank you.
BTW: Is there a way to only upgrade CB to stable releases instead of nightly? This would also reduce the amout of work for me to keep my 30+ CB installations up to date....

Please Log in to join the conversation.

1 year 1 week ago - 1 year 1 week ago #322541 by kondrich
Replied by kondrich on topic Nightly build of January 11th, 2021

beat wrote: If issue of empty member profiles persists, turn Joomla debug on in System / Global (joomla) configuration / System / Debug System, and see if there are any errors reported in the profile view ?


I restored the params column of the mentioned table already before downgrading. Now I enabled Debug Mode.

I saved CB configuration, marked "CB Core" plugin and Edit. Then I tried the same with "CB Forums" plugin (because I also restored params column of this plugin).
After opening CB plugins configuration, it opens a new plugin window and says:
Notice: Trying to get property 'id' of non-object in *physicalpathofmyinstallation*\libraries\CBLib\CB\Legacy\cbPluginHandler.php on line 476
and name is empty and "Global" pane is emtpy.

The following notices are displayed in user profiles:
Notice: Undefined offset: 0 in *physicalpathofmyinstallation*\administrator\components\com_comprofiler\admin.comprofiler.controller.php on line 260
Notice: Undefined offset: 0 in *physicalpathofmyinstallation*\administrator\components\com_comprofiler\admin.comprofiler.controller.php on line 263
Notice: Undefined offset: 0 in *physicalpathofmyinstallation*\administrator\components\com_comprofiler\admin.comprofiler.controller.php on line 267

I also realized that the CB configuration settings in Joomla backend does not look like the settings I restored in #_comprofiler_plugin id 1 row.
E.g.
Table:
date_format d.m.Y
time_format H:i:s
calendar_type 2

CB configuration backend:
Date Format: dd.mm.yyyy
Time Format: hh:mm:ss
Calender Type: Selection with Popup-Calendar (manually translated from German, it's the first option.
Can this be true?

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.208 seconds

Facebook Twitter LinkedIn