[Solucionado] Formulario de login junto el de registro no funciona

4 years 5 months ago - 4 years 4 months ago #278738 by entumas
Hola, tengo un problema.

Cuando selecciono la opción de que junto al formulario de registro aparezca uno de login, ese login no funciona, ¿alguien me podría ayudar a arreglar esto?

Estoy haciendo un sitio completamente privado y me gustaria hacer una pagina de inicio igual que facebook en la que hay en la misma pagina un formulario de login y uno de registro.
Para hacer esto he usado un plugin llamado Core Login Redirect con el que puedes elegir que formularios se muestran en login, registro, logout, etc, si los nativos de Joomla!, los de CB, JoomSocial, etc. Y he hecho que la pagina de login redireccione a la pagina de registro y en el formulario de registro he seleccionado la opción que te permite tener un formulario de login junto con el de registro. ¿Existe una forma nativa en CB de hacer esto sin el plugin que he usado?

Muchas gracias

Joomla! 3.4.8 - Community Builder 2.0.13

Please Log in to join the conversation.

4 years 5 months ago #278744 by Hertak
Hola, con CB no necesitas ningún plugin como el "Core Login Redirect" esto lo hace CB natuivamente.
Si pones un link hacia el registro aparecerá un módulo de login también ¿Has probado eso? el link quedaría como index.php?option=com_comprofiler&view=registers +tu itemid esto lo haces en el menú que desees.
The following user(s) said Thank You: entumas

Please Log in to join the conversation.

4 years 5 months ago #278745 by entumas
Hola Hertak, gracias por responder.

Core Login Redirect sirve para escoger la pagina que se ve en X caso, no para redireccionar despues del login.
La pagina es completamente privada, entonces cuando accedes a ella y aun no estas registrado Joomla! me mostraba el formulario de login nativo, es por eso que instalé Core Login Redirect, ya que este me permite elegir si se ve el nativo o el de CB. Sin CLR siempre me salía el nativo (nativo + CB si activaba el de CB).
Quizás es que este haciendo algo mal, si tu me sabes ayudar en esto estaria muy agradecido.
Se ha de tener en cuenta que yo lo que quiero es que al entrar en www.misitio.com se vea (o redireccione automaticamente al formulario) y que una vez logueado www.misitio.com se vea la homepage de mi sitio.

Aun así, este tema lo tengo "medio solucionado" con el CLR, como comento el principal problema que tengo ahora es que el formulario de login (solo cuando esta junto el de registro) no me loguea, solo recarga la página. :S

Please Log in to join the conversation.

4 years 5 months ago #278746 by Hertak
Complicado sin ver las cosas. Quizás con una mezcla de acl y módulos se puede arreglar sin problemas. Has visto si hay algún conflicto? ¿El módulo tiene iguales configuraciones que el componente?
The following user(s) said Thank You: entumas

Please Log in to join the conversation.

4 years 5 months ago #278747 by entumas
Si quieres te puedo dar por privado la URL y un usuario para que intentes loguear y veas el error.
¿Que es ACL?
No entiendo muy bien lo de las mismas configuraciones del modulo y el componente. El login es modulo y el registro va con el componente y no tienen las mismas opciones (creo). Si pudieras explicarte mejor lo agradecería :)

Please Log in to join the conversation.

4 years 5 months ago #278750 by Hertak
Envíame por privado y lo miro. Recuerda que yo no pertenezco al equipo de CB y si te ayudo es para dar una mano.
The following user(s) said Thank You: entumas

Please Log in to join the conversation.

Moderators: beatnantmarionetarhkrileonHertak
Time to create page: 0.440 seconds

Facebook Twitter LinkedIn