[Solucionado] Formulario de login junto el de registro no funciona

4 years 5 months ago #278785 by entumas
He de decir que tu idea me ha parecido genial, pero hay un problema. El inicio queda vacío
Es decir, yo accedo a:
Misitio.com, en el que como dices he creado el formulario de registro+login. Ese login redirige a:
Misitio.com/inicio, donde he puesto la pagina principal de la web.

Entonces esto funciona "bien", pero por ejemplo cuando estás en esa pagina en el breadcrumb pone:
Está aquí: Inicio > Inicio
El primer Inicio es el formulario de registro y si entro en él ya sea por el enlace del breadcrumb o por el logo de la web muestra un mensaje de error que dice que ya estoy registrado

¿He hecho algo mal? Por cierto el sitio sera multiidioma, por si eso pudiera influir.

Please Log in to join the conversation.

4 years 5 months ago #278787 by Hertak
Debes colocar algo ahí para los registrados así ven algo y ocultas el menú para que no se vea.

Please Log in to join the conversation.

4 years 5 months ago #278789 by entumas
Ya, pero yo lo que quiero que se vea es lo que hay en la pagina de inicio (la que se redirige al logearse), no quiero 2 paginas de inicio
:S

Please Log in to join the conversation.

4 years 5 months ago #278793 by Hertak
No tenfrías dos página de inicio si una sola que se muestra de una manera a unos y de otra manera a otros.
The following user(s) said Thank You: entumas

Please Log in to join the conversation.

4 years 5 months ago #278794 by entumas
Quizas no me he explicado bien, pero usando lo que dices, una vez logueado si le doy a "inicio" en el breadcrumb o le doy al logo, me va a la pagina de registro/login donde no se muestra nada, solo un mensaje de error.

Please Log in to join the conversation.

4 years 5 months ago #278796 by entumas
Mira de momento se me ha ocurrido una solución basándome en tu idea. :side:
He creado como pagina de inicio el registro, entonces en esa página he puesto un modulo que es el que muestra el contenido de la pagina de inicio y solo ven los registrados. Así una vez registrado, ves el contenido de la página que yo quiero que sea el inicio y sin el problema del "doble inicio". :woohoo:

Ahora bien aquí me faltan pulir dos cosas:
La primera es que sale un mensaje de error que reza: Error Ya ha iniciado sesión, se que este lo puedo ocultar con CSS, pero ¿existe una forma más limpia que evite que este mensaje se imprima en el HTML?

La segunda es que en el articulo de inicio original yo cargaba un modulo de un componente con {loadposition inici} y ahora no carga ese contenido. Esto creo que se tiene que arreglar con un plugin ¿conoces alguno?

¡Gracias por toda la ayuda!

Please Log in to join the conversation.

Moderators: beatnantmarionetarhkrileonHertak
Time to create page: 0.427 seconds

Facebook Twitter LinkedIn