Issue with CB italian translation

11 months 3 weeks ago #299463 by magostoni
Hi,
my site is bi-lingual - English/Italian, with Italian as the default.
The 2 languages work correctly on my site, except for the Community builder Italian translation. I am not sure if I have installed it correctly, but it is not displaying Italian.

I have used the CB installer to install the file 'plug_language_italian_it-IT_2.1.3.1.0+5a174de53.zip'.
It installed successfully, and it is visible on the 'Community Builder: Plugin Management' page with the name 'it-IT'. There are green ticks for 'installed' and 'published' and the access level is 'public'.

In the Joomla Language manager, 'it-IT' is set as the site default.

The site is displaying in italian, but for example the CB login module is displayed in english; same issue for CB advanced search.

Is there anything more I have to do to install the Community Builder Italian Language plugin ?

I am using Joomla! 3.8.2 Stable, and CB 2.1.3 (upgraded from 2.0.5)

When I run the 'Check CB plugins database' tool, the results include the line
'All CB plugin "it-IT" database is up to date.'

Thanks for any advice.
11 months 3 weeks ago #299465 by druskus
Ciao, hai impostato Joomla in Lingua Italiana? Forse potrebbe sembrarti una domanda stupida, ma se Joomla non è in lingua italiana il plugin di lingua non funzionerà, comunque l'installazione è corretta come hai fatto. Ho un sito in multilingua con CB e non riscontro problemi.

www.communitybuilders.it Supporto Italiano per Community Builder
11 months 2 weeks ago #299520 by magostoni
Hello,
I enabled System - Language filter plugin and now in the url I see "....&lang=it";
anyway, also in this way I continue to see CB login in english language and also CB Advanced search is displayed with english labels.


I checked and discovered a strange behaviour:

if I go under Extensions -> Language -> Installed I get 2 rows (1 for english and the other for italian); italian language is setted as default.

Then I created a new module (Language switcher) and published it in a position.
But the dropdown is empty and does not show the two languages to enable the choice.

Can anyone help me?
Attachments:
Moderators: beatnantdruskuskrileon
Time to create page: 0.362 seconds
Facebook Twitter Google LinkedIn