Having trouble with import

6 months 3 weeks ago #312054 by li_gordon
I'm having trouble importing this file..

1. I have set the 'not used field to be'
user_id,password,block,sendEmail,registerDate,lastvisitDate,activation,params,lastResetTime,resetCount,otpKey,otep,requireReset,alias,hits,message_last_sent,message_number_sent,avatar,avatarapproved,canvas,canvasapproved,canvasposition,approved,confirmed,lastupdatedate,registeripaddr,cbactivation,banned,banneddate,unbanneddate,bannedby,unbannedby,bannedreason,acceptedterms,acceptedtermsconsent

2. I set the delimiter to be a ,

3. my import data is attached

File Attachment:

File Name: people-lis...4-26.zip
File Size:53 KB


4 . Error: The delimiter is undefined
Attachments:
6 months 3 weeks ago #312055 by wolverton
Quotes in html tags and commas in some fields are causing issues.
Extra columns without headers are being created.

Attachments:
The following user(s) said Thank You: li_gordon
6 months 3 weeks ago #312073 by li_gordon
Thanks for the suggestion, but I'm still getting an error...

1. I adjusted the file to replace a " within the content with '
2. I opened the file using opreoffice, and it looks ok
3. I made sure to save the file in text wrangler with 'windows clrf'...
4. I also made sure the 'table headings' did not have quotes around them

do you see anything else that could be stopping this import?

Any way the 'error handling', co state where in the file it gets 'stopped'? Would help so much with debugging of my import...

File Attachment:

File Name: list-facul....csv.zip
File Size:53 KB


thanks,
Laura
Attachments:
6 months 3 weeks ago #312074 by li_gordon
I also tried to shorten the file to be just 3 records, and it still fails.

File Attachment:

File Name: people-lis....csv.zip
File Size:4 KB
Attachments:
6 months 3 weeks ago #312075 by wolverton
Please post screenshot of error.
6 months 3 weeks ago #312076 by li_gordon




This is with trying just the file with 3 rows...

I'm using a MAC, so it's possible there are some hidden characters, or the way the file was saved has some issues...

I have opened it in Libreoffice, and it looks good, I'm not seeing any extra 'columns', although there are MANY characters in some of the fields, no ", or special characters, although I could be missing something.

thanks,
Laura

File Attachment:

File Name: people-lis...4-29.zip
File Size:4 KB
Attachments:
Moderators: beatnantjciconsultwolvertonkrileon
Time to create page: 0.427 seconds
Facebook Twitter Google LinkedIn