[SOLVED] Translation doesn´t work

9 years 3 months ago - 9 years 3 months ago #158118 by Vicky2011
[SOLVED] Translation doesn´t work was created by Vicky2011
Hi there :)

I don´t know if it is a bug... but I´ve been trying to find out why my translated plugin doesn´t overwrite the english Language.

I installed the english language plugin, translated... uploaded, nothing changed. What did I do wrong??? The default language for CB is German. Do I have to rename the plugin?
Did I forget something??? Its just install plugin, translate language.php file (and Integration file and admin...), upload files...

I would be happy if you could help me with this :)

THANKS!!!

Please Log in to join the conversation.

9 years 3 months ago #158140 by krileon
Replied by krileon on topic Re: Translation doesn´t work
GJ uses its own language plugin. You'll find the english language plugin included with the GJ package. You will need to translate it to your language. CB language files and plugins provide zero translations for GJ 2.x.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 3 months ago #158146 by Vicky2011
Replied by Vicky2011 on topic Re: Translation doesn´t work
I translated files in comprofiler/plugins/language/cbgroupjiveen-gb. That should be the place of plugin language file, istn´t it?

Thanks!

Please Log in to join the conversation.

9 years 3 months ago #158161 by jojo12
Replied by jojo12 on topic Re: Translation doesn´t work
I want to answer how I did, and it's working well: I changed all in lang_cbgroupjiveenglish.zip to lang_cbgroupjivegerman.zip. Then I opened and changed the xml-file. I didn't change the filenames. then I rezipped all and installed. Now I have a cbgroupjivede-de.
Then I changed allways the second part of the lines with my german translation.
Perhaps that helps, but I know there's a group who is translating these files. I think they will soon publish the german translations.
The following user(s) said Thank You: Vicky2011

Please Log in to join the conversation.

9 years 3 months ago #158164 by Vicky2011
Replied by Vicky2011 on topic Re: Translation doesn´t work
Ok ... I will try to rename the zip file etc :) That could be the solution.

Thanks!!! :)

Please Log in to join the conversation.

9 years 3 months ago #158262 by jojo12
Replied by jojo12 on topic Re: Translation doesn´t work
Deutsche Sprachdateien für GroupJive 2.1 findest du in der Forge
forge.joomlapolis.com/projects/lan-gj-de/files

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.427 seconds

Facebook Twitter LinkedIn