[SOLVED] Deleting Groups Not Working

8 years 2 months ago - 8 years 2 months ago #178109 by GoremanX
Running the latest GroupJive 1.4 with CB 1.7 on Joomla 1.5.23 and Firefox 7.

When I try to delete a group, either in the backend or frontend, I get a blank page and the group is not deleted. This is true whether the group is published or unpublished.

If I turn on error reporting, then instead of the blank page I get this error:

Fatal error: Call to undefined method cbgjData::filterArray() in <span>/</span>var<span>/</span>www/clients/client1/web1/web/components/com_comprofiler/plugin/user/plug_cbgroupjive/plugins/cbgroupjivephoto/cbgroupjivephoto.php on line 763 Fatal error: Class 'JLoader' not found in <span>/</span>var<span>/</span>www/clients/client1/web1/web/libraries/loader.php on line 161


If I try to delete the group repeatedly, I always get either that blank page or the error message, but eventually the group really is deleted. It can take 3 to 4 tries.
8 years 2 months ago #178115 by dougbuchan
When trying to create, delete, or edit Groups I get the blank white page with:
"Fatal error: Call to a member function get() on a non-object in /home/me/public_html/www.mysite.org/components/com_comprofiler/plugin/user/plug_cbgroupjive/plugins/cbgroupjivefile/cbgroupjivefile.php on line 593"

Doug Buchan
Buchan Consulting LLC
www.BuchaConsulting.com
8 years 2 months ago #178117 by GoremanX
Sorry, can't confirm this. I have no problems creating or editing groups in either the backend or frontend. For me, it's just deleting groups that's the issue.
8 years 2 months ago #178133 by krileon
Please install GJ 2.4 and its integrations (only those you intend to use or are already using). The error is for code that does not exist anymore and was only present with GJ 2.4 RC1-2 meaning something was not upgraded.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
8 years 2 months ago #178151 by GoremanX
I must've missed one of the integrations or something when doing the installation. I just re-installed them all and now it works fine.
Moderators: beatnantkrileon
Time to create page: 0.416 seconds
Facebook Twitter Google LinkedIn