Deletion of Groups

7 years 11 months ago #185911 by gcdi
Hello There,

I've just added a long list of groups, I mean a very long list.

1.) I meant to delete 3 groups
2.) I marked the 3
3.) I clicked "Delete"

RESULT: ALL Groups were deleted!!!!!!

This MUST be a potential Bug!!!!
7 years 11 months ago #186098 by krileon
Joomla version? CB version? GJ version? That's not likely to happen unless you clicked the all checkbox maybe by mistake. If your other groups were nested groups of those 3 then they of course would be deleted as well as a nested group can't exist without its parent.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
7 years 11 months ago #186103 by gcdi
Joomla 1.7.3
CB Version 1.7.1
GJ 2.4

This is certainly a bug. I just replicated it. Here's the situation:

one group nests another nests another. Hence, I have three levels. I delete child 1 and child 2 and all other groups were deleted as well.!

I did not click all checkboxes by accident!

If you like record a video to demonstrate the bug!
7 years 11 months ago #186105 by krileon
That's working as intended. I just explained in my previous post a nested group can't exist without its parent. Example as follows

Group 1
- Group 2
- - Group 3
- - Group 4
- - Group 5
- - Group 6

With the above if I delete Group 2 then Groups 3-6 also get deleted.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
7 years 11 months ago #186138 by gcdi
Not quite, I have to beg you differ. In your example you are deleting Group 2 and therefore groups 3 - 6 are deleted as well. This makes sense and would work as intended, if it weren't for the fact that group 1 would be delete as well, and all other parent groups!

To give you a better idea, here's my example:

Group A
--Group 1A
--Group 2A
---Group 1-2A
Group B
Group C
--Group 1C
--Group 2C

Now, if I were to delete Group 1-2A, Group 1A and Group 2A, ALL Groups (B, C, 1C, and 2C) are deleted as well!!!
7 years 11 months ago #186228 by krileon
Well that certainly shouldn't happen. Will take a look to see what could be causing this.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.420 seconds

Facebook Twitter LinkedIn