Solved: J1.6 / 1.7 / 2.5 Non created admin menus

11 years 5 months ago - 10 years 4 months ago #157512 by slabbi
It has been reported from a few users that admin menus on Joomla 1.6 and Joomla 1.7 have not been created after installation of uddeIM.

This is a known problem that appears on some Joomla sites for several components.

When you see this error after a uddeIM installation it is most likely that you have tried to install the wrong package, i.e. the package for Joomla 1.0/1.5 on Joomla 1.6/1.7/2.5.

To avoid or fix this problem:
  1. Ensure that you have not upgraded Joomla from version 1.6rc or earlier.
    Upgrading from 1.6 stable to a newer one is ok.
  2. Ensure that you are installing com_uddeim_j16 on Joomla 1.6 or above (or when your server upload size is limited use com_uddeim_j16_english_only). You can also try (**2).
  3. When menu links are still not created (Joomla has already created wrong entries), then
    1. Deinstall uddeIM.
    2. Remove all uddeIM releated entries from jos_menu and jos_extensions (**1).
    3. Reinstall com_uddeim_j16.

The problem only appears very rarely but lots of components are affected, see Google .

For more information see this post

It seems that Joomla sometimes writes invalid menu entries and stumbles across them when you try to repeat the installation. Currently there is no solution for this problem which exists from Joomla 1.6 and better.

(**1) You can clean up your database tables using following two commands (you may have to change the prefix "jos_"):
DELETE FROM jos_menu WHERE link LIKE '%uddeim%'
DELETE FROM jos_extensions WHERE element='com_uddeim'

(**2) You can also install uddeIM this way when there is an upload limit or you have other problems uploading/installing uddeIM (e.g. "There was an error uploading this file to the server." or "Please enter a Package directory"):
Use "Install from URL" with a fully qualified link to the file, e.g. or do a local installation.

The short version for dummies (Joomla 1.7 or better only):
  1. Deinstall UddeIM
  2. Execute following SQL commands in order to clean up your database (you may have to change the prefix "jos_"):
    DELETE FROM `jos_menu` WHERE `link` LIKE '%uddeim%'
    DELETE FROM `jos_extensions` WHERE `element`='com_uddeim'
  3. Reinstall UddeIM using the correct package ( or when your server has an upload limit of 2mb)

uddeIM & uddePF Development
CB Language Workgroup
CB 3rd Party Developer
The following user(s) said Thank You: vfwhite, lurecoral

Please Log in to join the conversation.

10 years 6 months ago - 10 years 6 months ago #189151 by JimBC
For Joomla installed sites. I have found a simple fix to this. No guarantee it will solve everyone's problem. If you install uddeIM and it shows it installed but the admin failed. YOU DON'T have to uninstall. Go to your administrator(back end of your site) Extensions/Manage scroll through and look for the uddeIM administrator component then make a note of the id# that Joomla assigns to it.
File Attachment:

Now go to your sites phpMyAdmin, then look for your Joomla Database click on it. When it opens look for the jml_menu table. Then click it and then scroll through till you find the COM_UDDEIM_MENU, tick the box and click edit. Then in the component_id int(10) unsigned place your uddeIM ID # in the box farthest out to the right then save or go button. Then look back in the administrator Components and you should see uddeIM PMS.

File Attachment:

That's it Good Luck to all. Hope this helps.

Please Log in to join the conversation.

10 years 6 months ago #189193 by slabbi
Thanks a lot JimBC, this sounds reasonable.
I will add this to the FAQ document!

Nevertheless I hope that people will not longer install the wrong version because I have split the archive into two (one for J1.0/1.5 and one for newer versions).

uddeIM & uddePF Development
CB Language Workgroup
CB 3rd Party Developer

Please Log in to join the conversation.

10 years 6 months ago #189268 by JimBC
Well I tried and tried many times to get it to install, it just would not work. I think it has something to do with joomla just not liking the component ID#. Or it just has something to do with what stuff is loaded into the site as in plugins and modules before uddIM is installed. I installed it with no problems on a clean joomla 1.7.3 stable install with nothing but jdownloads and Kunena forum. It went in flawlessly, but on another joomla 1.7.3 stable site with other plugins and modules it would not install for nothing. Thats when I found in the database it was simply just not adding the uddIM ID# once I manually added the ID number it has worked just fine. Thanks enjoy.

Please Log in to join the conversation.

10 years 4 months ago #197064 by wolfsauge
I am afraid I am a super-dummy, since the dummy solution does not work for me :blush:
When I try to clean the database table I get this:
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'DELETE FROM `jos_extensions` WHERE `element`='com_uddeim'' at line 2
I also do not understand (you may have to change the prefix "jos_")
- change to what?
And it gets worse. According to JimB I should go to the database: When it opens look for the jml_menu table.
There is no jml_menu.
I am sorry I have never learned to use the database. Is there any simple solution?

Please Log in to join the conversation.

10 years 4 months ago #197084 by Richard67
Hi wolfsauge,

when you installed Joomla, there was automatically created a random database tables prefix, which you may or not may have changed during installation.

This prefix appears at the beginning of each table name of all Joomla database tables, instead of the "jos_" mentioned in the example.

You can look up the database tables prefix in your global configuration in the joomla backend on the "server" page, or in the joomla configuration file configuration.php

I hope this helps a bit.

Please Log in to join the conversation.

Moderators: beatnantslabbikrileon
Time to create page: 0.167 seconds

Facebook Twitter LinkedIn