adding an apostrophe (') to the language file

16 years 3 months ago #16270 by meedja
Brian

I'm the poster on Joomla.org referenced. I have exactly the same issue. Mine is an Irish site so virtually every other user is O'Somethingorother.

I too made the backslash' edit as described but it had no effect (presume it goes directly after %s with a space then Profile Page' retained as is?)

Help appreciated.

Peter

Please Log in to join the conversation.

16 years 3 months ago #16271 by beat
meedja wrote:

Brian

I'm the poster on Joomla.org referenced. I have exactly the same issue. Mine is an Irish site so virtually every other user is O'Somethingorother.

I too made the backslash' edit as described but it had no effect (presume it goes directly after %s with a space then Profile Page' retained as is?)

Help appreciated.

Peter


Looks like a bug...?!

A few questions to help me pinpoint the problem:

So the problem is on names only ? first name ? last name ?
What's your setting of names ? only 1, 2 (first+last name in separate fields) or 3 (with also middle-name) ?

Usernames should not accept single-quotes...

What are your php settings (magic_quotes_gpc in particular ?)

Does this happen on registration only, or also on front-end user-edit ?

Finally, what's stored in the SQL database (when you look with phpMyAdmin) ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

16 years 3 months ago #16274 by meedja
beat wrote:


Looks like a bug...?!

A few questions to help me pinpoint the problem:

So the problem is on names only ? first name ? last name ?
What's your setting of names ? only 1, 2 (first+last name in separate fields) or 3 (with also middle-name) ?

Both firstname and last name fields. Configured only 1,2 (first+last in seperate fields)

Usernames should not accept single-quotes...

Correct

What are your php settings (magic_quotes_gpc in particular ?)

magic_quotes_gpc on locally & globally.
Php 5.1.4
Apache Release 10336100

Does this happen on registration only, or also on front-end user-edit ?

Occurs on registration AND front-end user edit.

Finally, what's stored in the SQL database (when you look with phpMyAdmin) ?

Database fields contain the correct apostrophe.

Please Log in to join the conversation.

16 years 3 months ago #16275 by beat
Thanks for the infos. Please log as a bug on forge on cb-bug-tracker with a link to this thread, will look into this when i get to it...

Maybe if you can add a few screen-dumps, to exactly see it can help reproducing.

Thanks,

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

16 years 3 months ago #16276 by brianfischer74
Replied by brianfischer74 on topic Re:adding an apostrophe (') to the language file
Medja posted his information regarding your questions.

I have a bit of different information that he had. Most of it is the same as seen below.

name settings is first and last name

Cannot find the "usernames should not accept single quotes"
so I don't know that answer

Happens on registration and front-end user edit.

PHp version is 4.4.2 Here is what my php.ini shows for matic quotes.

Magic quotes
magic_quotes_gpc = On ; magic quotes for incoming GET/POST/Cookie data
magic_quotes_runtime= Off ; magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
magic_quotes_sybase = Off ; Use Sybase-style magic quotes (escape ' with '' instead of \')


However my database appears different than Medja's. The apostrophe doesn't show up correctly and is replaced by code. I can edit the database and it corrects it.

Will see about psting this on the forge. New to this. Maybe Medja will beat me to it and get this posted.

Thanks to both of you for working on this.

Post edited by: brianfischer74, at: 2006/06/30 00:59

Post edited by: brianfischer74, at: 2006/06/30 01:03

Please Log in to join the conversation.

16 years 6 days ago #21691 by mpausch
Hi, I tried the backslash' but it didnt fix the problem.

my line in the language file reads..
DEFINE('_UE_PROFILE_TITLE_TEXT','%s Profile Page');
added the backslash' after the '%s but didnt work.

An interesting observation.. I have 2 joomla sites both with CB. 1 has the name style set to single name field. Thats the 1 that doesnt work.

The other is set to first and last name field. That one doesnt have the problem.

Looks like the issue might be related to this setting.

My Joomla version is 1.0.11 Stable [ Sunbow ] and CB is 1.0.1

Any ideas?

Post edited by: mpausch, at: 2006/09/29 07:23

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.214 seconds

Facebook Twitter LinkedIn