Username in URL instead of UserID

15 years 9 months ago #22644 by mraburn
Username in URL instead of UserID was created by mraburn
hey guys,

I cannot seem to get Usernames in the query to work, only by userid.

How do I enable this?

index.php?option=com_comprofiler&task=userProfile&user='name'


will not work, only...

index.php?option=com_comprofiler&task=userProfile&user=ID

People are using the rewrite friendly URLs but that URL is no longer valid.

Thanks for any help!

Please Log in to join the conversation.

15 years 5 months ago #32708 by lexa
Replied by lexa on topic Re:Username in URL instead of UserID
I have the same problem! Please help! I can use only the IDs! :S

Please Log in to join the conversation.

14 years 11 months ago #45219 by ramzy83
Replied by ramzy83 on topic Re:Username in URL instead of UserID
Same problem here, I noticed that on joomlapolis the both are working
www.joomlapolis.com/index.php?option=com_comprofiler&task=userProfile&user=63
or
www.joomlapolis.com/index.php?option=com_comprofiler&task=userProfile&user='beat'

How can I do that?
PS: I don't need to create homepages and 'subdomains' per user,but just replace the UserID by the username

Thank you for you help.

Please Log in to join the conversation.

14 years 10 months ago #46580 by sfraise
Replied by sfraise on topic Re:Username in URL instead of UserID
I'm having the same issue as well, did anyone figure this out?
I have to be able to pull profiles by username instead of userid in order to work with our chat program.

Please Log in to join the conversation.

14 years 10 months ago #46584 by sfraise
Replied by sfraise on topic Re:Username in URL instead of UserID
Ok I resoved the issue, here's what I did:

In the url code you need to add the '%%' to it like this:
/index.php?option=com_comprofiler&task=userProfile&user='%USER%'

Post edited by: sfraise, at: 2007/09/25 01:49

Please Log in to join the conversation.

14 years 1 month ago #66188 by brian420
Replied by brian420 on topic Re:Username in URL instead of UserID
Thank you very much for pointing me in the right direction. To avoid any confusion, however, what worked for me was just the &user='USER' without the %'s. Don't mean to bump an old topic but figured it may help others who were stuck such as myself. :)

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.426 seconds

Facebook Twitter LinkedIn