redirection on connection.

15 years 6 months ago #32574 by chessman
redirection on connection. was created by chessman
Hi,

i use last version of CB (1.0.2) with JSMF 2.0.2 and joomla 1.0.12.

When i use cblogin from my web site with a www.mysite.com url it redirect to mysite.com/http://www.mysite.com so it doesn't work good. But when i use mysite.com to login in cblogin it works good. Do u know how to change some settings to make it good??

Second problem, when i use captcha plugin for security, i can't create new account : error message is "invalid security code". It is same for the already registered users when they try to recover a lost password.

Thanks for your answers cause i got about 500 members on the web site and don't want to loose them for this type of troubles.

Post edited by: chessman, at: 2007/03/06 08:14

Please Log in to join the conversation.

14 years 8 months ago #54567 by cgc0202
Replied by cgc0202 on topic Invalid Security Code
I cannot believe no one has responded to this yet. I have teh same situation, whether the captcha was turned on or not in the login

Please Log in to join the conversation.

14 years 8 months ago #54570 by nant
Replied by nant on topic Re:Invalid Security Code
cgc0202 wrote:

I cannot believe no one has responded to this yet. I have teh same situation, whether the captcha was turned on or not in the login


posting to an old thread might not give you answers.

this area is about CB 1.0.2.

what is your exact problem?

Please Log in to join the conversation.

14 years 8 months ago #54578 by cgc0202
Replied by cgc0202 on topic Re:Invalid Security Code
nant wrote:

cgc0202 wrote:

I cannot believe no one has responded to this yet. I have teh same situation, whether the captcha was turned on or not in the login


posting to an old thread might not give you answers.

this area is about CB 1.0.2.

what is your exact problem?


Sorry Nick,

I downloaded the CB 1.1, and was able to install the components, modules, and the captcha plugin.

I like the "audio" that goes with the captcha, by the way. I am developing a site where the visitors may have difficulty seeing "blurred" letters, and the "audio" helps -- assuming they do not have difficulty hearing.

Anyway, that worked. Now, the Joomla sites where I have stored CB already have some registered users that were approved. It seems the registered users specific designations (e.g., regirtered, author, etc.) were also stored in the CB users profile, so that is good.

However, when I tried to login, I get this error:

Invalid Security Code

The only problem with the above note was that, I did not enable the captcha for the login module. I changed the password, because initially I thought that might be the "security code" it was asking, but it was not.

So, I enabled the captcha for the "login moduule", and I was not getting the captcha with the login module, as it showed in the "registration module".

I checked it several times, turning it on or off. Then, I checked if there was a separate module for the captcha (which would not make sense) but as expected, there was none, because they should go in tandem with the registration, login, etc. modules.

As a last resort, I "published" the default login module, and I was able to login properly. My username appeared both in the "Who's online" and the "CB Online" modules.

What was I missing, as far as enabling (or turning off) the captcha option, in relation to the login?

Otherwise, it would be one of the features I am looking for.

There are other features that I thought would come with the Community Builder, but I would address that once I have been able to straighten out the "login" problem.

Thanks.

Cornelio

Please Log in to join the conversation.

14 years 8 months ago #54580 by nant
Replied by nant on topic Re:Invalid Security Code
The CB 1.1 login module should have an extra parameter to enable captcha plugin integration.

A similar parameter needs to be set in CB Captcha plugin parameter settings.

You can turn both off if you dont want captcha in cb login module.

Please Log in to join the conversation.

14 years 8 months ago #54583 by cgc0202
Replied by cgc0202 on topic Re:Invalid Security Code
nant wrote:

The CB 1.1 login module should have an extra parameter to enable captcha plugin integration.

A similar parameter needs to be set in CB Captcha plugin parameter settings.

You can turn both off if you dont want captcha in cb login module.


Thanks for responding quickly Nick,

The solution is not to use captcha. To begin with, I chose CB1.1 among those I have evaluated so far, partly because of the captcha. It works with the registration.

My question is: Why did it not work with the "login module" -- resulting in the "Invalid Security Code"?

Even if I checked "Not" for the "login process", I did not have the captcha showing, alright, but I also got the error message -- "Invalid Security Code".

As you pointed out: "The CB 1.1 login module should have an extra parameter to enable captcha plugin integration.

A similar parameter needs to be set in CB Captcha plugin parameter settings."

In a round-about way, what I was asking was what file and what script do I change so that I will not get the "Invalid Security Code" error message, when I or other registered members log in.



Cornelio

N.B.

The interim solution that I did right now is to answer no to both of this:

Include Captcha check in CB Login: Yes No

Include title for security input box on CB Login form:

Post edited by: cgc0202, at: 2008/01/18 00:25

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.354 seconds

Facebook Twitter LinkedIn