set_time_limit?

13 years 1 week ago #20643 by ivokwee
I can't upload an image. I get this warnig.

Warning: set_time_limit() has been disabled for security reasons in /home/www/dce46286ecf020495d7619c0f81be80a/web/administrator/components/com_comprofiler/imgToolbox.class.php on line 95


I check images/com_profiler and plug_profilegallery are set to 777. And I know my local Joomla install has no problems. Is it a permission problem, or a server setting (like the function set_time_limit). Help please?


Thanks,

Ivo
13 years 1 week ago #20652 by nant
Obviously its a server setting that causes the resizing functionality built in CB (working off a library like GD2 or other) to fail.

This should probably cause avatar image uploads to fail in CB (please verify).

At this point I see no work-around but will check.

Sorry.
13 years 1 week ago #20655 by beat
ivokwee wrote:

I can't upload an image. I get this warnig.

Warning: set_time_limit() has been disabled for security reasons in /home/www/dce46286ecf020495d7619c0f81be80a/web/administrator/components/com_comprofiler/imgToolbox.class.php on line 95


I check images/com_profiler and plug_profilegallery are set to 777. And I know my local Joomla install has no problems. Is it a permission problem, or a server setting (like the function set_time_limit). Help please?


Thanks,

Ivo


Thanks for reporting.

Added a check if this function is not disabled before calling it in next CB version.

In the mean time you can simply comment out that line 95 from administrator/components/com_comprofiler/imgToolbox.class.php by simply adding a // at begin of that line, and report back here if all works fine now.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
13 years 1 week ago #20657 by ivokwee
Nick, Beat,

Thanks for helping so quickly.

Nick, I tried uploading a new avatar. Seems to work fine.

Beat, I commented out set_time_limit, it goes further but now I have and error (now inside the CBgallery tab):

Image ToolBox failure! - Please notify system admin - Error occurred during the moving of the uploaded file.

Strange, because avatar uploading works fine.

Ivo
13 years 1 week ago #20659 by ivokwee
SOLVED IT!!

Sorry, sorry. Kind of "my" fault. I have set the permissions under images/comprofile/plug_profilegallery to 777, but not the ones below! (the user folders). At home the files are owned by the DB user, but at the remote site the FTP user and DB user are different. Phew....

This permission stuff in Joomla is a kind of annoying....

Anyway, Nant and Beat thanks.
Moderators: beatnantkrileon
Time to create page: 0.397 seconds
Facebook Twitter Google LinkedIn