Fatal error/ xajax_0.2.4/failde to open stream

13 years 1 month ago #77848 by Everyman
cb connector is working well in a subsite but I get the following error message in the main site

Warning: require_once(/.../public_html/mambots/system/xajax_0.2.4/xajax.inc.php) [function.require-once]: failed to open stream: No such file or directory in /.../public_html/components/com_comprofiler/plugin/user/plug_cbconnector/cbconnector.php on line 31

Fatal error: require_once() [function.require]: Failed opening required '/home/timetend/public_html/mambots/system/xajax_0.2.4/xajax.inc.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/timetend/public_html/components/com_comprofiler/plugin/user/plug_cbconnector/cbconnector.php on line 31


After getting this message I checked for and installed xajax 0.2.4 but still get the message.

When I click on [function.require]link the following message appears

The requested URL /administrator/function.require-once was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

sh404sef was uninstalled after too many problems with Fireboard and not enough time.

So I checked the data base found and and dropped 2 sh404sef records but I don't know where the 404 error pages maybe stored.

Can you help please.

Post edited by: Everyman, at: 2008/10/21 01:25

Please Log in to join the conversation.

13 years 1 month ago #77931 by geeffland
What version of Joomla are you using? What version of PHP?

If using J1.5 then that is the issue...

If using J1.0.x then the next possible issue is that something possibly from your older sef extension is causing the issue. Require_Once is a built-in php function so unless you have a special build it should be there.

CB3PD Developer - CB Connector (formerly phpBB Connector) plugin

Please Log in to join the conversation.

13 years 1 month ago #77948 by Everyman
I am sorry for not leaving you this info firstly,

Joomla 1.0.15
PHP 5.2.6

Yes, I suspect that the problem stems from sh404sef. I have removed it and mysql sh404sef tables. I suspect there is more sh404sef data somewhere but don't know where or how to find it.

Also, in my control panel when I click on "More Components..." under the "Components" menu it takes me home not to components, and I don't know how to fix it either. This too stems from sh404sef, I suspect.

What do you mean, "Require_Once... should be there?"

Thanks for watching and helping

Post edited by: Everyman, at: 2008/10/22 05:35

Post edited by: Everyman, at: 2008/10/22 05:35

Please Log in to join the conversation.

13 years 1 month ago #77988 by geeffland
the function Require_Once is a built-in php function... Can not think of a reason why your php should not have it...

Back on the sh404sef... Not an expert on that area but my guess is that you have an .htaccess file that is redirecting links on your site to the sef format...

First look for them... if you find them then download a local copy and rename the one on the server. I say download because you will want to review the file and make sure there is not some other needed code in that file... On my webhost there is no need for a new .htaccess file under normal conditions... I have one to force it to php5 but other than that nothing else is in the file...

Let me know what you find...

CB3PD Developer - CB Connector (formerly phpBB Connector) plugin

Please Log in to join the conversation.

13 years 1 month ago #78085 by Everyman
Thank you for watching and responding.

New problems:

.htaccess keeps disappearing

- so I went to see if xajax was still there too to find that is was not in the right folder
- fixed that
- now have access to CB Connector BUT

Cannot access front end:

-I log on in IE and get "The website declined to show this webpage"; More info - "This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the website, but it does not have permission to view the webpage."
- I go in through administrator and check User Manager and it says that I am logged in

Now what?

I have two other Joomla 1.0.15 and one 1.5 installations in subdirectories and work with one daily without problems. Do we need .htaccess for each site?

Post edited by: Everyman, at: 2008/10/23 19:49

Please Log in to join the conversation.

13 years 1 month ago #78114 by Everyman
Another forum mentioned an .../includes/joomla.php file; I checked it out; a huge chunk was missing. So I copied the file over from another installation; low and behold, all is well.

Thank you geeffland for your help.

Wm

Please Log in to join the conversation.

Moderators: beatnantgeefflandmartijn189krileon
Time to create page: 0.187 seconds

Facebook Twitter LinkedIn