"Your email failed to send! Please try again.

12 years 1 month ago #46343 by fengle
I encountered this problem when I send an email to any users. I am sure the mailer setting is correct since I can get user registration email and new entry in profile book notification without any problem.

Anyone have a idea? My site is www.citysportsinfo.net , you are welcome to have a free test. Thanks!

BTW: I also have problem with either joomla default contact component or CB contact. The above mentioned issue maybe be relevatnt I guess.

Shiau

Post edited by: fengle, at: 2007/09/22 02:46
12 years 1 month ago #46352 by fengle
The following is my server setting, maybe it is helpful to figher out the problem:P

Database Version: 5.0.27-community-nt-log
PHP Version: 5.1.2
Web Server: Microsoft-IIS/6.0
WebServer to PHP interface: cgi-fcgi
Joomla! Version: Joomla! 1.0.13 Stable [ Sunglow ] 21 July 2007 16:00 UTC
Relevant PHP Settings:
Joomla! Register Globals Emulation: ON
Register Globals: ON
Magic Quotes: ON
Safe Mode: OFF
File Uploads: ON
Session auto start: OFF
Session save path: c:windowstemp
Short Open Tags: ON
Output Buffering: OFF
Open basedir: none
Display Errors: ON
XML enabled: Yes
Zlib enabled: Yes
Disabled Functions: none
12 years 1 month ago #46385 by beat
try changing joomla global email settings, or contact your hoster.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
12 years 1 month ago #46520 by fengle
beat wrote:

try changing joomla global email settings, or contact your hoster.


Can you give me more explanation? such as what I should ask for from my hoster?

My users can't send emails though CB email function, but they DO get emails including followings:
CB registration email
User reports
Connection request notifiation


And I just find out if I set the parameter "Emails sent "From:" " @CB backend to "admin-reply to-user" instead of user address,emails then can get through!
12 years 1 month ago #46531 by beat
fengle wrote:

beat wrote:

try changing joomla global email settings, or contact your hoster.


Can you give me more explanation? such as what I should ask for from my hoster?

My users can't send emails though CB email function, but they DO get emails including followings:
CB registration email
User reports
Connection request notifiation


And I just find out if I set the parameter "Emails sent "From:" " @CB backend to "admin-reply to-user" instead of user address,emails then can get through!


Yup. Right. Good find, thanks for sharing. That's why this setting is there for.

Explanation, also as reference to others who search forum:

1) Some hosters allow only emails to be sent from their server which have a "from" address with a domain-name which is hosted on their server.

2) Also some email-hosters accept emails only from a host which is in the "SPF" record of the corresponding domain-name.

Now that has a small privacy drawback, since bounced/returned-emails's subjects will be seen by the admin instead of the user. This is explained in the setting's explanation:

Setting for Send-to-User Email forms: Sender formating: Choose between:

  1. "From:" User Email Address (no "Reply-To:" field):
    User receives all replies and error reports, for better privacy)
  2. "From:" Admin Email Address, with "Reply-To": User Email Address:
    This is SPF spam-checking compliant, but admin may receive errors/erroneous replies


Anyway, good that you could find solution to the problem, and that it was already included in CB. :)

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
Moderators: beatnantkrileon
Time to create page: 0.439 seconds
Facebook Twitter Google LinkedIn