[SOLVED] Registration error

12 years 6 months ago #64507 by farseer
[SOLVED] Registration error was created by farseer
Hi there,

Props to the whole CB team for a great new release. Thanks.

I have encountered a small registration problem. Everything works great, until I turn on sh404sef. Then I get this when I try to register a new account:

You are not authorised to view this resource.
You need to login.

After registration it is directing to the main component and I'm not sure why. Anyone got any suggestions?

Thanks

Post edited by: Rapunzl, at: 2008/09/18 20:24

Please Log in to join the conversation.

12 years 6 months ago #64518 by beat
Replied by beat on topic Re:Registration error
Try clearing SEF cache of sh404sef, it might solve your problem...

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

12 years 6 months ago #64589 by farseer
Replied by farseer on topic Re:Registration error
Hi Beat,

No, that's not the problem.

Here's what I have found, if I go to sh404 and set it to "do not override sef_ext" for Comprofiler, everything works.

Only problem now is that CB is inserting the name and surname of the user into the profile URL. I need it to be the username only. Any idea how to change that? My CB config is set to use username only.

Thanks

Post edited by: farseer, at: 2008/06/04 12:49

Please Log in to join the conversation.

12 years 6 months ago #64595 by beat
Replied by beat on topic Re:Registration error
CB does not do SEFing in joomla 1.0/mambo.

In Joomla 1.5 core SEF mode, CB SEFes now user profiles and lists nicely :)
But for profiles only username is used, not names.

So that must be coming from somewhere else.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

12 years 5 months ago #64718 by belamb
Replied by belamb on topic Re:Registration error
I also faced this problem with CB 1.1 and Joomla 1.0.15. Curios that i encountered it while other people kept registering at my page.

I solved it by publishing the component menu link to community builder

index.php?option=com_comprofiler&Itemid=173

to public access.

before it was visible only for registered users.

Is there a better way to create a link to "My Profile"?

I'm also using a SEF component (artio)

regards

Please Log in to join the conversation.

12 years 5 months ago #64738 by farseer
Replied by farseer on topic Re:Registration error
Hi Beat,

Well after lots of changing and trying of different settings, I have managed to get it working. Now I was changing so many things, that I'm not sure exactly what solved the problem in the end. And I'm not too experienced on Joomla. If anyone else has this problem they are welcome to contact me and I will share the settings I ended up with!

I suspect that it had something to do with the fact that I published the user's name and surname to the contact info tab (only visible to super-admin, but there and published). When I removed that info from the tab it disappeared from the URL. Like I said, I'm not too experienced and from what I understand that shouldn't make a difference, but it sure seemed to!

thanks

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.420 seconds

Facebook Twitter LinkedIn