problem after upgrading to 1.2

12 years 2 months ago #67438 by bscunningham
Replied by bscunningham on topic Re:problem after upgrading to 1.2
OK, this story wasn't done. :sick:

It turns out this was two problems that looked like one. The first, editing users in the fron end was cured with the JCE update. The second was editing users on in the back end. There is a bug in the currently published Nates Gallery.
The final clue showed up after upgrading to 1.2 RC2

On Saving in back end I got the following pop up error. In 1.2 RC1 the pop up was blank.

The page at www.spaclique.com says:moscomprofiler::store failed: Unknown column 'cb_pglasupdate' in 'field list' SQL=UPDATE jos_comprofiler SET `user_id`='109',`firstname`='Zackie',`middlename`='',`lastname`='Boykin',`hits`='90',`message_last_sent`='0000-00-00 00:00:00',`message_number_sent`='0',`avatar`='jwd_reverse288594sampleAvatar80.jpg',`avatarapproved`='1',`approved`='1',`confirmed`='1',`registeripaddr`='65.174.218.131',`cbactivation`='',`banned`='0',`banneddate`='0000-00-00 00:00:00',`unbanneddate`='0000-00-00 00:00:00',`bannedby`='0',`unbannedby`='0',`bannedreason`='0',`acceptedterms`='1'...............



The Fix was to edit Nates Gallery: /componanta/com_comprofiler/plugin/user/plug_cbprofilegallery/cb_profilegallery.php Line 1607
Change
$user->cb_pglasupdate = $cb_pglastupdate;
To
$user->cb_pglastupdate = $cb_pglastupdate;

Seems Nate was right after all. It wasn't a .js issue, it was a Nate issue.:evil:

"Once you go MAC you never go back"
Bill Gates

Please Log in to join the conversation.

12 years 2 months ago #67440 by bscunningham
Replied by bscunningham on topic Edit - Save User Errors Front and Back Ends
Change thread title

"Once you go MAC you never go back"
Bill Gates

Please Log in to join the conversation.

12 years 2 months ago #68902 by undoIT
Replied by undoIT on topic Re:problem after upgrading to 1.2
Nice catch! Thanks for sharing the solution.

btw, affected file name is "cb.profilegallery.php", at least in my install of CB 1.2 RC2

Please Log in to join the conversation.

11 years 11 months ago #76552 by pagecafe
Replied by pagecafe on topic Re:problem after upgrading to 1.2
Thank you so much for sharing this solution! That was the issue and your explanation solved it in less than 5 minutes of searching and making the patch.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.427 seconds

Facebook Twitter LinkedIn