e-mail confirmation code does not work

11 years 4 months ago #66236 by rollen01
I have registration setup so that people receive a confirmation e-mail and I have 2 problems.

1. E-mails aren't sent the first time they register but they do when they try to login again.

2. The confirmation link does not work and sends them to a page that says they do not have the authority to see it.

"Greetings Edward,
Thank you for applying for registration with us. We have
received your request and we will process it as soon as you
confirm your email address by clicking on the following
hyperlink:

loot-box.com/index.php?option=com_comprofiler&task=confirm&confirmcode=

Once your email address is confirmed our moderators will be
notified to continue the activation process.
You will be notified by email of the progress of your registration process.
Email : rollensmail@gmail.com
Username : testdummy

Kind Regards,
Website Administration Team

NOTE: This email was automatically generated from Loot-Box ( loot-box.com )."


This is the exact e-mail i dunno if its suppose to have a numeric code at the end of the link or not but it doesn't so I'm thinking thats the problem. IF some one can be generous enough to help me I would appreciate it.
11 years 4 months ago #66242 by nant
Just tested it on your site.
Registered just fine.
Received the email with the proper confirmation link.

I did notice a js error at the end of the registration process - looks like something with your template.

Error: uncaught exception: Permission denied to call method Location.toString

Error: uncaught exception: Permission denied to call method Location.toString
11 years 2 weeks ago #76309 by sboldfield
hi,

I have the same issue - no confirmation code in the new users email:

Greetings steveO,
Thank you for applying for registration with us. We have received your request and we will process it as soon as you confirm your email address by clicking on the following
hyperlink:

buydirectdubai.com/index.php?option=com_comprofiler&task=confirm&confirmcode=

Once your email address is confirmed our moderators will be notified to continue the activation process.
You will be notified by email of the progress of your registration process.
Email : steve@capeverdeportal.com
Username : Steven0

Kind Regards,
Website Administration Team

NOTE: This email was automatically generated from Dubai Property Real Estate - Rent, Buy or Sell Property in Dubai ( buydirectdubai.com ).

This link does not work - can anyone help?
11 years 2 weeks ago #76312 by sboldfield
seems to be caused by adding a new field - getting the error:

There are 1 column(s) missing in the comprofiler table, which are defined as fields (rows in comprofiler_fields):

- Field cb_age - Column cb_age is missing from comprofiler table.

This one can be fixed by deleting and recreating the field(s) using components -> Community Builder -> Field Management.
Please additionally make sure that columns in comprofiler table are not also duplicated in users table.
11 years 2 weeks ago #76313 by nant
sboldfield wrote:

seems to be caused by adding a new field - getting the error:

There are 1 column(s) missing in the comprofiler table, which are defined as fields (rows in comprofiler_fields):

- Field cb_age - Column cb_age is missing from comprofiler table.

This one can be fixed by deleting and recreating the field(s) using components -> Community Builder -> Field Management.
Please additionally make sure that columns in comprofiler table are not also duplicated in users table.


if you do this do thinks then work?
11 years 2 weeks ago #76315 by sboldfield
no i have deleted the field and recreated using Field management - and have the same issue
Moderators: beatnantkrileon
Time to create page: 0.391 seconds
Facebook Twitter Google LinkedIn