3:Strange ALT Text: "Unknown User" for Thumbnail

11 years 5 months ago #64358 by Terp
This issue is now fixed in Community Builder 1.2 RC 2.
Community Builder 1.2 RC 2 is a recommended upgrade.




I preface all my posts with the fact that I am totally new to CB, so disregard if this is standard operating procedures. ;)

I was trying to make a list of 'newest members' and have, say, the latest 10 users' thumbnails in a list.

When there is no 'username' published in the listand just the thumbnail, the alt text when one does an onmouseover says, "Unknown user." If, however, I publish the username in the same list, it displays the username for the alt text.

With no username published, it clearly knows the name, as you click on it and the URL points to the user's profile. Shouldn't the alt text variable be equal to the username associated with that thumbnail?

[screenshot attached]

Also, how would you limit the list to the last 10? I sorted by "member since" in ascending order, but not sure how you enter a 'latest 10' query. :) Would it be as simple as a top N in SQL in the advanced field?

[code:1]
SELECT TOP N MemberSince
FROM User TableName
[code:1]

Again, being new, I still need to figure out the tables and variables, but does this work? ;«») [/code:1] [/code:1]

Post edited by: Terp, at: 2008/06/03 01:03

Post edited by: beat, at: 2008/06/04 14:57

Post edited by: beat, at: 2008/07/01 14:02
Attachments:
11 years 5 months ago #64583 by beat
Yes, the username is a small bug, but still bug.

Moving this thread to the bugs forum.

The number of entries per page is a global parameter of CB lists, for now.

The LIMIT 10 that you would have to add to the query is done separately of advanced search based on the entries per page limit. So you can't specify this for now.

We added a new parameters area in users-lists, hope there will be soon all needed/required settings on a per list basis there. Maybe we will unfreeze that part and add that for next release...

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
11 years 4 months ago #66956 by beat
This issue is now fixed in Community Builder 1.2 RC 2.

Community Builder 1.2 RC 2 is a recommended upgrade.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
Moderators: beatnantkrileon
Time to create page: 0.425 seconds
Facebook Twitter Google LinkedIn