Ajax Email checker - Wont Disable

11 years 2 months ago #68650 by beat
Thanks for sharing the fix, highly appreciated :)

The ajax checker enabling/disabling is for the frontend. In backend it's always enabled, by deisgn.

Question: do you think that it also makes sense to disable also in backend when it's disabled in frontend ? (I found it very handy on a site, to avoid mistyping email addresses in backend)

Or was it always enabled in frontend as well ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
11 years 2 months ago #68654 by drewsu2
Hi Beat,

The front end shuts off when I set it to NO, so all was good there. It was just the backend that wouldnt shut off, so if I was going to make any changes to the email address itself or even add a new user (in the backend), it wouldnt allow me to do that because of this email error:

Checking......"Could not check this email: Please double-check: Needed for confirmation."

So, I tried just disabling the AJAX all together so I didnt get that error and thats when I realized that it wouldnt shut off in the backend.

For the site that I am building, I only want our moderators to add new users and most of the time they would be doing this in the backend, so the front end wasnt as important to me personally.

I think that in the new version, having an option to turn off AJAX in the front end only, backend only, or both would be a great addition. Thats what I think anyways.

Also, if you have an answer to the (Checking......"Could not check this email: Please double-check: Needed for confirmation.") error when AJAX is enabled, please let me know.

Thanks Beat for all that you do with CB!!!
11 years 1 month ago #70385 by sunnyjey
I am also getting this error..even after updating cb core file as mentioned in same forum.

Joomla 1.0.15
Apache Server
Php 5.4

Any help will be highly appreciated.
11 years 1 month ago #70417 by drewsu2
hmmm...Have you gone into your configuration/registration and set the AJAX username and email to NO?
11 years 1 month ago #70419 by sunnyjey
Actually I want this feature. Last few months I have lost many members just because they entered wrong or incomplete email address..

I hope developer provide us solution for this bug...
10 years 9 months ago #80409 by kimelaine
I am having the same problem. Unfortunately, this fix didn't work for me. I am using Joomla 1.5.2
I want to load all our users (nearly 500) onto the new site from the backend and have had no success.

The only way I can do it is to set the user up in Joomla User Manager, then go to Community Builder User Manager, add more info, save, then go back in and select "approved" and "confirmed".

If the user registers through the front end and I have confirmation turned off, it works okay.

Any help would be greatly appreciated. The roll out of the new site is on hold till we can figure this out!

Post edited by: kimelaine, at: 2008/11/25 02:23
The following user(s) said Thank You: davidfowkes
Moderators: beatnantkrileon
Time to create page: 0.412 seconds
Facebook Twitter Google LinkedIn