Ajax Email checker - Wont Disable

11 years 3 months ago #68252 by drewsu2
Wow...nobody has an answer for this yet?

Since I cant figure it out and since this thread has almost been ignored (except for Rupunzl & mikemontague...TY) with almost 100 views, Im going to outsource this to joomalancers and actually pay someone to help figure out this problem.

Once we figure out the problem, I will post the solution here in hopes that others can benefit.
11 years 3 months ago #68373 by burgos
Hi there drewsu2, I'm having same issue ;) and I think it's actually a BUG :evil: on CB 1.2 RC 2.

This post is very importante B) and somebody from CB team should take care of it.
Here's more info: Ajax email and username checker always works when adding users with CB User Manager, although those are set to "No", and that can be seen on CB config file:
$ueConfig='0'; $ueConfig='0';

There is no way to set it off! :huh:
11 years 3 months ago #68379 by nant
drewsu2 wrote:

Wow...nobody has an answer for this yet?

Since I cant figure it out and since this thread has almost been ignored (except for Rupunzl & mikemontague...TY) with almost 100 views, Im going to outsource this to joomalancers and actually pay someone to help figure out this problem.

Once we figure out the problem, I will post the solution here in hopes that others can benefit.


Nothing has been ignored.
I have compiled a list of potential new issues that I have sent to Beat to review.

Hopefully, he will be able to look into some of these within the next couple of days and post feedback and maybe even potential fixes.

Non of the issues (in my opinion) are show stoppers (meaning not severity 1 issues).

Beat and other developers are in the process of setting up a new Joomlapolis server environment.

I have been reading and answering close to 100 posts and emails per day and also working on new documentation.

People helping out on the forums are highly appreciated in my book B)
11 years 3 months ago #68450 by drewsu2
As promised, the solution to this AJAX Email and Username Checker Issue.

I decided to pay someone on Joomlancers.com to try and figure out this problem, so Tony Burgos bid on my project and figured it out for me, so I would like to share his solution here so that others may benefit and also hope to encourage others to help out even if they are not code savvy by outsourcing and hiring a programmer. You can do this by going to joomlancers.com and submitting your project to be bid upon.

This is how you to fix this problem:

Download the attached: cb.core.php file and copy it to the directory below by overwriting the existing file (good idea to backup original file first):

components/com_comprofiler/plugin/user/plug_cbcore/

Thats it! You can always download the file and then compare with the original what was fixed, but this a lot easier.

The problem was that if you go in the backend and try to register a new user via CB User Manager, you couldnt without the AJAX Email Checker and Username running. It still ran even though we set it to NO in the configuration/registration tab for Ajax email and username.

This fix will allow you to turn it on and turn it off and have it actually turn off when you set it to no...which means, that it now works 100%!

Hope this helps!

Attachment cb-e6430760a7eb0165ba34f0f3ab85d5ae.zip not found



Post edited by: drewsu2, at: 2008/07/15 23:44
Attachments:
11 years 3 months ago #68459 by Rapunzl
Very nice of you to share your solution. Upped that karma for you! :cheer:

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction
11 years 3 months ago #68644 by mikemontague
It Works!! Thanks for posting the fix man!
Moderators: beatnantkrileon
Time to create page: 0.428 seconds
Facebook Twitter Google LinkedIn