#7: Multiple Field Orders set to 0

11 years 2 months ago #69175 by WebMuse
I think there is a bug. This happened to me multiple times yesterday. Unfortunately, I'm under a deadline of late next week, so I won't be able to get back to determine specific set of actions where this occurs. Here's what I did yesterday.

In Field Manager, first I moved several of the fields from "Additional Information" into "Contact Info" tab. Also added a few new fields to "Cotnact Info", some text and some delimiter, maybe a checkbox.

Created two new tabs: host and facilitator.

Defined fields for both these tabs. As I was creating fields for these new tabs, occasionally, I forgot to reset the tab setting, and had to go back in to change this.

As these new fields were created, not just one, but after a few, or maybe after moving one out of the wrong "Contact Info" tab, I notice that the ordering I had established in the "Contact Info" tab was messed up. So I re-ordered them, and then continued to add more fields, only to see the ordering lost again.

So, I stopped re-ordering until I thought I was done adding new fields. Then, as I went to re-order, there were over 10 out of 18 fields on Contact Info that were assigned position '0' (zero).

This really appears to be a bug. Thought you might want to look into it. Please post a request if you'd like me to recreate it, when I have time in early August.

I'm running J! 1.5.3 Native mode, and CB 1.2 RC2

Post edited by: beat, at: 2008/07/30 22:29

WebMuse G
11 years 2 months ago #69185 by rpitera
At first I was thinking; you do realize that each TAB POSITION has it's own ordering, right? But you're not talking about the tab manager, you are speaking of the field manager.

One of my only complaints about CB is that there is no way to filter in the tab and field lists so you only see the fields in a given tab or the tabs in a given position.

This to me would ease much of the confusion of ordering.
11 years 2 months ago #69194 by Rapunzl
I also noticed this, but I think it was resolved by manually typing the order # in the order space and hitting the save button over the ordering column. It probably does need to be addressed.

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction
11 years 2 months ago #69196 by WebMuse
rpitera, I agree that being able to select just a subset based on Tab would be wonderful, but I can live with it the way it is, just have to scroll to the bottom all the time. Also would like ability to select "show all rows", which is now available other places within Joomla 1.5

Rapunzl,
Yes, I did reorder these fields. The problem is that after I did this, by typing unique order position numbers for that given Tab, and clicking on ReOrder icon, they did reorder, but this ordering was LOST after adding additional fields. This should NOT have happened!!!

Many of the fields were set to position of "0" (zero), even after I and specified a different position earlier.

Because of this BUG I must re-validate and correct the order of the fields after EVERY time I've worked to add additional fields. What a PAIN!

WebMuse

WebMuse G
11 years 2 months ago #69207 by Rapunzl
Sorry Muse. I understand your frustration now. Have you tried the arrows to move them up and down in ordering or does that have the same effect? I know it's tedious, but it's a maybe-quick-fix till this is resolved.

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction
11 years 2 months ago #69319 by beat
Rapunzl (or anybody else) could you reproduce this problem ?

WebMuse, please do a CB -> tools -> check CB database: is all green ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
Moderators: beatnantkrileon
Time to create page: 0.390 seconds
Facebook Twitter Google LinkedIn