Confirmation Emails

11 years 2 months ago #74793 by Mel75
Hello,
sorry, my english isn't so good.
I have installed joomla 1.5.7 and the cb 1.2 rc2.

Now i have user registration allowed, but nothing happened. No email is received by an user.

What is my fault?
I have checked everything.

Please help :o)

Greets
Mel
11 years 2 months ago #74797 by Rapunzl
Mel, your user registration under Joomla Global Configurations should be set to no. Also, make sure you disable the mod_login and enable cb_login under Extensions/Module Manager. Do you require moderator approval or email confirmation under CB/Configuration/Registration?

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction
11 years 2 months ago #74804 by Mel75
yes, i have set the registration on global to no.
i have also mod cb_login enabled...
and i need moderator approval and email confirmation.

Post edited by: Mel75, at: 2008/09/19 10:28
10 years 11 months ago #83778 by katandmouse
Hi,
We're not getting confirmation emails either. It used to work and can't figure out when or why it stopped. I just upgraded to RC 4 in hopes of fixing the problem. Still doesn't work. Our site is www.planetherbs.com

New users are having to contact the administrator who has to approve them.

Administrator is not getting a copy of the email either.

Please help. The administrator is not happy. :-(

Kathy

Post edited by: katandmouse, at: 2008/12/31 22:46
10 years 11 months ago #83796 by katandmouse
Hey all,
I changed the config to send emails via PHP instead of SMTP and it worked.

This led me to the reason this failed in the first place.

We had the SMTP account in the global config set to the administrator's email address using authentication. At some point the administrator reset and changed her password but did not update these config settings with the same. Then when the system tried to send the email, it failed because it could not authenticate.

To hopefully prevent future problems, I set up a noreply@...com account and set it to forward to the administrator. I'm using that in the config instead with the hope that no one will ever have a need to change that password because no one will actually be retrieving emails from that account.

Hopefully, this solution will save others some grief.

Kathy

Post edited by: katandmouse, at: 2009/01/01 08:41
Moderators: beatnantkrileon
Time to create page: 0.426 seconds