CB goes Captcha!

13 years 3 months ago #35663 by spacewalk
Replied by spacewalk on topic Re:CB goes Captcha! CHECKED GD
Nick A.'s the expert here, but it does look like you don't have typographical support in GD. And typography is at least half of what a captcha is. So that may indeed explain your problem.

Please Log in to join the conversation.

13 years 3 months ago #35697 by rockbust
Replied by rockbust on topic Re:CB goes Captcha! CHECKED GD
I am having a problem with the image not displaying for captcha and I have read the entire tread and can not find a solution. I have been asured by my host that I have freetype installed at
/usr/lib/libfreetype.so.6.3.7
/usr/lib/libfreetype.so.6

When I check php info I see
GD Support enabled
GD Version bundled (2.0.28 compatible)
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled


Is Free type installed?

Post edited by: rockbust, at: 2007/04/15 22:56

Please Log in to join the conversation.

13 years 3 months ago #35701 by geogeogr
Replied by geogeogr on topic Most possible SOLUTION
Trust me, ALL of you who have the same problem, Do this, and you WILL be saved.

FROM WHAT I UNDERSTOOD AFTER 1 hour trying to fix the problem with the image Not showing, And reading all those pages, the result is:

I believe that most of you actually (like me in the beginning) used Dreamweaver, or just a simple HTML editor to "look" at the beginning and end of your language files.


WRONG MOVE, it is definately TRUE what was said, that you WILL NOT see ANY BOM marks there.

1. DOWNLOAD Notepad++ which you can find FREE using google (GNU opensource)

2. Install it

3. Use an FTP manager (FileZilla is what I used) to Download the first file we need to work on, which is www.yourjoomlasite/language/yourlang.php (e.g. english.php or french.php or greek.php like mine was) and save it to, let's say C:\ root)

4. Open the php file using Notepad++ ... now, you won't even see the BOM marks there, BUT it can remove them. Do this:

5. Your file is most likely UTF-8. Go to Format, and select "Encode in ANSI". Then go to Format again, and select UTF-8 without BOM. Save your file.

6. Upload it back to your webserver. Be sure to keep a copy on the server if anything goes wrong (e.g. rename yourlang.php to OLDyourlang.php before puting the new one up)

7. WE're NOT done YET! ;) Go find the SECOND file we need to edit, which is the com_comprofiler (CB component) language file! Now, this one is either www.yourjoomlasite/components/com_comprofiler/plugin/language/default_language/default_language.php if your site is in, let's say English, or blahblah/plugin/language/YOURlanguage/YOURlang.php where YOURlanguage and YOURlang is the language in which your site is published, like we did for the first file. Download this one to your PC too, using the FTP client. It's ok if it replaces the previous one we downloaded and changed (which already is back on our site, changed).

8. Do exactly the SAME procedure as explained in steps 4, 5 and 6 with this file too.

9. Go try your site now. :-) It should work fine.

IF it doesn't, do the same thing with your main template file (joomla template folder, that is). ALSO FIRST, be sure that the 2 files you changed are the actual files being used by your site, e.g. the english.php with default_language.php or the greek.php with greek.php etc.

LET US ALL KNOW if my solution works for you.

Georgios, Greece.

Please Log in to join the conversation.

13 years 3 months ago #35736 by larralex
Replied by larralex on topic Re:Most possible SOLUTION
Done exactly as described and no result. Image is not showing. From what I see others having the same problem have GD 2.0.28 bundled, just my case too. Gd info is:
GD Support enabled
GD Version bundled (2.0.28 compatible)
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled

Is there something missing?? thanks!

Edit:

FIXED, Thanks Nick!

Post edited by: larralex, at: 2008/01/01 19:49

Please Log in to join the conversation.

13 years 3 months ago #35751 by nant
Replied by nant on topic Re:Most possible SOLUTION
larralex wrote:

Done exactly as described and no result. Image is not showing. From what I see others having the same problem have GD 2.0.28 bundled, just my case too. Gd info is:
GD Support enabled
GD Version bundled (2.0.28 compatible)
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled

Is there something missing?? thanks!


freetype support

Please Log in to join the conversation.

13 years 3 months ago #35757 by gigi
Replied by gigi on topic Re:CB goes Captcha!
thanks a lot for the SMF fix (disabling 'Use database driven sessions')!

just curious, it says in the SMF help file that enabling this feature speeds up the forum, did anyone experience slower performance after you disabled it? or any other problems?

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.502 seconds