CB goes Captcha!

11 years 9 months ago #50917 by TheFlyingKiwi
Hi Nant, Beat and the rest of the community.

I have read the entire thread and again must add my thanks to Nant for continually answering the same questions. Now, unfortunately, I must add my problem as well. I have recently moved moved my site from one server to another. Captcha worked gloriously on original server but does not work on the new server.

Various aspects of troubleshooting (eg replacing language files, uninstalling/reinstalling etc etc... pretty much everything mentioned on this thread) and have concluded it must be a server setting.

and YES GD2 is enabled with Freetype ;)

OK here is the crucial info:
Joomla 1.1.3, CB 1.1, Captcha 1.0

From CB Configuration -> Images:
ImageMagick Auto-detected ImageMagick 6.3.5
NetPBM Not installed
GD1 library Not installed
GD2 library Auto-detected, bundled (2.0.34 compatible)

From PHPInfo:
PHP Version: 5.2.5
Apache/1.3.37 (Unix)
gd
GD Support enabled
GD Version bundled (2.0.34 compatible)
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.1.9
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XPM Support enabled
XBM Support enabled

OK, here's the killer blow:
I have another website, running from the same account on the same server, same version of J!,CB and Captcha and it works :pinch:

I'm clean out of ideas now and would be very grateful for any guidance.

Most grateful as always,
Iain
11 years 9 months ago #50939 by beat
captcha version 1.0 is touchy on a forgotten empty line or space in any changed php file. you will see that if you check error logs in webserver you get "headers already sent" errors + not validating website because of this as well.

Tired of such bugs, we took lots of time to rewrite completly that in version 2.0 of captcha, to get immune to these errors. Please see front-page article for v 2.0 :)

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
11 years 9 months ago #50967 by TheFlyingKiwi
Beat, I take your point and believe me I am extremely grateful for hard work you guys have done and I fully recognise the limitations of a free product. My point certainly wasn't a criticism - moreover curiosity. I have learnt a huge amount since I was first exposed to Joomla 18 months ago and I am continuing to learn. The main issue for me is that it worked on one server and not the other SO is there something else that is causing a bigger issue? For example - could it be a permissions issue?
11 years 9 months ago #50970 by TheFlyingKiwi
I have upgraded to Captcha 2 and all issues have been resolved
11 years 9 months ago #51405 by aditya4olive@hotmail.com
Hi i have installed the image captcha in registration form but the image is not displaying.In IE the path its giving is this http://192.168.91.181/mahalife2/index2.php?option=com_comprofiler&task=tabclass&Itemid=1&tab=getcaptchatab&no_html=1
What do i do can anyone help its urgent
11 years 9 months ago #51437 by TheFlyingKiwi
have you read the entire post? there are plenty of solutions throughout the post and if it still fails then chances are you will have upgrade. According to Beat's post above - there are no other answers available. V1 was a little buggy.
Moderators: beatnantkrileon
Time to create page: 0.393 seconds